Bug 53803 - [sblive] noise when playing .wav files (emu10k1)
[sblive] noise when playing .wav files (emu10k1)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: AfterStep (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-19 04:32 EDT by martin.macok
Modified: 2007-04-18 12:37 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-04 22:31:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.config which I used to compile -ac10 with (21.99 KB, text/plain)
2001-09-19 05:49 EDT, martin.macok
no flags Details
diff between non-working and working .config (7.00 KB, text/plain)
2001-11-11 11:14 EST, martin.macok
no flags Details

  None (edit)
Description martin.macok 2001-09-19 04:32:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010918

Description of problem:
I've got SB Live 1024 soundcard.
When I upgraded to current rawhide (kernel-2.4.9-0.5) I hear noise when
playing wav files.
When I use "play file.wav" (play from "sox") I hear a noise like cat
/bin/sh >/dev/dsp. When I use "xmms file.wav" I here noise just at the
beginning (~0.2s), then I hear the rest of the wav correctly. "xmms
file.mp3" or "xmms file.ogg" works well without noise.
This doesn't happen with older rawhide's or public beta's kernels (2.4.7-*)
and this also doesn't happen with 2.4.2/2.4.3 from rh71.This also doesn't
happen with plain vanilla 2.4.9 and alan's 2.4.9-ac5 and -ac10.
/etc/modules.conf:
alias eth0 3c59x
alias parport_lowlevel parport_pc
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :
alias usb-controller usb-uhci
alias char-major-89 i2c-dev


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot with kernel-2.4.9-0.5
2. play some/file.wav
	

Additional info:
Comment 1 Arjan van de Ven 2001-09-19 05:33:03 EDT
Now this is weird; there are no patches to the emu10k driver and 2.4.9-0.5 is
based on 2.4.9-ac10 ......
Comment 2 martin.macok 2001-09-19 05:41:59 EDT
So this is strange, because when I boot to -ac10 the sound is perfect and when I
boot to -0.5 it plays noise.
The only differences between those two are:
ac10 was compiled (by me) with gcc-2.96-97 and 0.5 is (probably, I don't know
for sure) compiled with gcc-2.96-97.1 (the athlon binary from rawhide).
ac10 was compiled with a different .config than rawhide's binary kernel.

If you want, I can
1) try to recompile ac10 with current gcc
2) provide .config and dmesg's
Comment 3 Arjan van de Ven 2001-09-19 05:44:40 EDT
The .config would be a good start; I really doubt it's a gcc thing as gcc is
rather stable, only very very obvious bugfixes go in.

Thanks
Comment 4 martin.macok 2001-09-19 05:49:59 EDT
Created attachment 32138 [details]
.config which I used to compile -ac10 with
Comment 5 martin.macok 2001-10-04 22:10:56 EDT
Still not fixed with kernel-2.4.9-0.18 - when I use the "play" command I hear
noise. When I run "play" repeatably I hear different noise (like with different
frequencies - f and 2f ...?)

This doesn't happen with -ac16 and -ac18 (compiled with previously attached
.config).
Comment 6 Need Real Name 2001-10-20 13:49:27 EDT
I have (about) same sound problem.
After upgrading kernel with up2date
rpm -q kernel
kernel-2.4.9-6
Comment 7 Trond Eivind Glomsrxd 2001-10-20 14:45:36 EDT
Happens for me as well... play starts working again (I used 
/usr/share/sndconfig/sample.au 
) after getting sound from another source, like xmms.
Comment 8 Need Real Name 2001-10-20 17:04:25 EDT
Same problem with my system. I upgraded the kernel from 2.4.3-12 to 2.4.9-6,
using up2date and
the sound was damaged (playing wav files or realplayer sounds like noise). If I
run sndconfig I
can still hear Linus's voice correctly but no music. If I return to the 2.4.3-12
(boot using "linux.bak" from Lilo), the sound is OK.
I am pretty sure that this upgrading to kernel 2.4.9-6 is responsible for
breaking the sound.
I have a SiS530 motherboard with on board sound (C-Media PCI).
Thanks,
V.
Comment 9 Stephen John Smoogen 2001-10-24 23:26:14 EDT
Ok, I am wondering if the problem is in either the sound layer and not the 
emu10k. The reason is that while I have duplicated the bad sound problem 
between 2.4.7-10 and 2.4.9-7.. I am also getting odd clicks on my Dell 
Inspiron laptop which has a completely different sound chip. The problem is 
more attenuated when using the i686 kernel on the laptop and less so with the 
i386 kernel.

Hope this helps pin it down.
Comment 10 Alejandro Gonzalez Hernandez - Imoq 2001-11-03 01:06:06 EST
I have exactly the same problem, under Enigma with kernel 2.4.9-7

I have a Soundblaster mp3+ 5.1
Comment 11 Need Real Name 2001-11-03 05:43:33 EST
I just upgraded to kernel 2.4.9-12 via up2date
There is still a sound problem.

Sometimes the sound is good.
Most of the time it is heavly distorted.
Or for the most part distorted.
Or i hear just to clicks.

The last kernel where the sound worked well was kernel 2.4.3-12
Which was also installed via up2date
Comment 12 martin.macok 2001-11-05 02:02:08 EST
I'm getting:
noise with 2.4.9-13 (rh72 updates).
good (no noise) with 2.4.10-ac10, ac11, ac12, 2.4.12-ac3 (compiled by my own
with                            
         .config from attachment 32138 [details])
noise with 2.4.13-ac5 (compiled by my own).

The noise behaves this way (see first message of this bug first):
First execution of "play file.wav" pops usually just at the beginning and plays
the rest of file good. Second execution generates noise with regular popping.
Third execution generates noise with regular popping at different
frequency...etc. When I try it several minutes/hours later, behaves same (first
ok, second and further generates noise). Playing files with xmms sometimes just
pops the sound at the beginning but never generate noise like "play".

I saw this also on LKML, see 
http://marc.theaimsgroup.com/?l=linux-kernel&w=2&r=1&s=emu10k+buzzing&q=b
but I saw just one message which contains something interesting and related to
"what the hell is going on" ->
http://marc.theaimsgroup.com/?l=linux-kernel&m=100489267207609&w=2
> The current emu10k1 driver uses a hardware clock to generate periodic
> interrupts. These apparently ran at the wrong rate in some Alpha machines.
> It's possible that the same problem occur now with more recent i386
> machines.
(my machine is Athlon 850 and Asus KT133A VIA)
Comment 13 Tom Diehl 2001-11-05 10:08:02 EST
FWIW: I have a athlon 1.0 gig with 1gig of memory and the SB live sound card. 
I too experience this problem with the 2.4.9-7 kernel. I also discovered that 
under kde going into the sound server cntl center and adjusting the audio 
buffer response time decreases/eliminates the buzzing noise.
Comment 14 martin.macok 2001-11-11 11:14:49 EST
Created attachment 37222 [details]
diff between non-working and working .config
Comment 15 martin.macok 2001-11-11 11:18:19 EST
Attachment id 37222 shows diff between 2 .configs of 2.4.15-pre2. With previous
config I heard noise, with newer I don't.

(JFYI: 2.4.15-pre2 has ext3 support merged in already...)
Comment 16 Hetz Ben Hamo 2001-11-22 06:27:57 EST
I had those problems also - I suggest to use the CVS driver from 
opensource.creative.com and FOLLOW the instructions there (specially if you 
have 2 speakers or if you got SPDIF)..

They Makefile there have some problems detecting which kernel version you're 
running (it detects the UP,SMP, and the enterprise kernels all at once and 
naturally fails to install the modules - so change the KERNELVERSION line to 
somthing like:

KERNELVERSION := 2.4.9-13

would do the trick to compile. Also - don't forget to REMOVE any emu10k1, 
ac97_codec modules or they will clash at each other in the resolve).

Thanks,
Hetz
Comment 17 Bruce Garlock 2001-11-28 13:30:59 EST
I have the same problem, however I noticed when I loaded the gameport driver for this soundcard,
 which used to be 'ns558', and now is 'emu10k1-gp' that I can now hear the proper sounds when
using 'play'.  I have not hammered on it enough to get it to mess up again, but I wonder why after
I loaded the emu10k1-gp module, that the fuzz went away.

I'm using RH 7.2, 2.4.9-13
Comment 18 Bruce Garlock 2001-11-28 19:41:39 EST
I still have the "noise" after trying some other apps.  CivCTP will not even
play any sound.  Anyone have any solutions?  I even tried a few of the
opensource.creative.com snapshots, but still get the noise.
Comment 19 Trond Eivind Glomsrxd 2001-11-28 19:46:21 EST
I don't use any gameport, and have it happening on two very different machines
(i840, dual PIII and a Athlon/Via - the SB Live!s are different models as well).
Comment 20 Bruce Garlock 2001-11-28 19:55:17 EST
ok, after adjusting the sound server ctl in KDE, my problems seem to have gone
away.  I adjusted it to the lowest level, and I can now hear sounds in CivCTP. 
Also, the 'play' command seems to work now.
Comment 21 Bruce Garlock 2001-11-29 08:49:52 EST
well, I thought all was well until I tried the 'play' command this morning, and got the noise again. 
I'm almost ready to go back to linus 2.4.4 where I had no problems.   Is there an ext3 patch for
linus 2.4.4?
Comment 22 Bruce Garlock 2001-11-29 12:51:39 EST
someone else has entered this as a bug on opensource.creative.com

http://opensource.creative.com/bugzilla/show_bug.cgi?id=272
Comment 23 Bruce Garlock 2001-11-30 09:32:39 EST
I have had better results by recompiling 2.4.9-13, with High Memory support turned off.  Can
anyone try this and see if the problem is better?
Comment 24 martin.macok 2001-12-20 12:45:18 EST
I changed this:

-CONFIG_HIGHMEM4G=y
+CONFIG_NOHIGHMEM=y

and

-CONFIG_SOUND_DMAP=y
+# CONFIG_SOUND_DMAP is not set

In 2.4.17-rc2 and the problem is over.
Comment 25 Matt Arnold 2002-01-04 22:31:02 EST
Following advice on the emu10k1 developer's Bugzilla database entry for this
problem, I installed kernel-2.4.9-13.i586.rpm instead of the i686 version I had
been using. After doing that, all my sound distortion problems went away. Any
idea why this would fix that particular bug? I haven't noticed any new problems
as a result of this. FWIW, my system is a Celeron 400a, 256M RAM, BX chipset
mobo, SoundBlaster Live!, Red Hat 7.2 with all available updates.
Comment 26 Arjan van de Ven 2002-02-11 11:44:31 EST
The emu10k1_new driver in 2.4.9-21 should also fix this.
Comment 27 Need Real Name 2002-03-03 13:04:55 EST
> The emu10k1_new driver in 2.4.9-21 should also fix this.

It does not for me with kernel 2.4.9-21..
I changed 'emu10k1' to 'emu10k1_new' in /etc/modules.conf

alias sound-slot-0 emu10k1_new
alias sound-service-0-0 emu10k1_new
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
post-install emu10k1_new /etc/emu10k1/setemu
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :


I get still sound, no sound or bad sound.
"play /usr/share/sounds/KDE_Beep_Bottles.wav" gives me a 'tick' then silence and
then again a 'tick'.

Any ideas on how to solve this ?

The last kernel which had good sound was the kernel 2.4.2-2 which came with the
red hat 7.1 install.

Kernels 2.4.3-12, 2.4.9-6, 2.4.9-12 and 2.4.9-21 had all bad sound.
Comment 28 Matt Arnold 2002-03-08 20:57:52 EST
The emu10k1_new driver does not help me either with the Athlon version of kernel
2.4.9-31. As my previous comments on this bug would indicate, I also had this
problem on my old Celeron-based system with the i686 kernel. This bug should be
reopened because it is clearly NOT fixed. I've had this problem with every Red
Hat 7.2 kernel that's come down the pike. I can't remember which one was the
last one to work with 7.1. I know it worked fine with the default RH 7.1 kernel.
Comment 29 Brian Ryner 2002-03-14 01:42:38 EST
The emu10k1_new driver _does_ fix the problem for me, on 2.4.9-31.  I'm using a
Dell Dimension 4100 (Pentium 3/1GHz)
Comment 30 Need Real Name 2002-05-02 08:34:34 EDT
I have am Athlon 1 GHz, a VIA KT266 board and a SB Live!, running Red Hat 7.2,
kernel 2.4.9-31 *with* emu10k1_new.

Essentially, I used to have *two* problems:
1. sometimes crackling noise instead of sound. With the "play" command, this
noise typically extended over the whole sound file played, whereas with realplay
it was only at the beginning (~.2 secs).
2. The first  ~.5 secs of a sound played is missing, the last ~.5 secs is
repeated (!). So if I played a sound file containing a voice saying "I go to
Berlin", I sometimes hear "go to Berlin Berlin":

I re-compiled the kernel with the suggested changes, (CONFIG_NOHIGHMEM=y,
CONFIG_SOUND_DMAP is not set). This solved the first problem for me, but not the
second (!).

Any ideas?

Note You need to log in before you can comment on or make changes to this bug.