Bug 538041 - libguestfs tools (particularly virt-df) should ignore domains with ID 0
libguestfs tools (particularly virt-df) should ignore domains with ID 0
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
: 538064 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 06:51 EST by Richard W.M. Jones
Modified: 2010-03-16 13:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 12:55:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-11-17 06:51:12 EST
Description of problem:

 Example using virt-df on Xen:

 # virt-df
 Domain-0 seems to have no disk devices

 (virt-df doesn't die, but the warning is annoying).

Version-Release number of selected component (if applicable):

 # virt-df --version
 1.0.76

How reproducible:

 When using Xen, always.

Additional info:

 libvirt has declared the special domain with ID 0 as the
 "control plane OS".  The only hypervisors which work like
 this are Xen and HyperV.  When we see a domain with ID 0
 we should get the libguestfs tools to ignore that domain.
Comment 1 Richard W.M. Jones 2009-11-17 09:06:15 EST
*** Bug 538064 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.