Bug 538115 - [raw-config] Conflict on file editing does not seem to resolve itself cleanly.
[raw-config] Conflict on file editing does not seem to resolve itself cleanly.
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
unspecified
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: John Sanda
: SubBug
Depends On:
Blocks: rhq_spearhead
  Show dependency treegraph
 
Reported: 2009-11-17 11:47 EST by Corey Welton
Modified: 2010-12-16 09:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 09:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2009-11-17 11:47:34 EST
Description of problem:
If I edit on filesystem and immediately try to make changes on the UI, i /do/ get an error message that reads (twice): 

NOTE: This resource's configuration is currently being updated by the RHQ agent. The configuration cannot be edited until the update in progress is complete.

This, however, never seems to go away, and I am not sure my changes -- either change, filesystem or UI -- ever show up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. $platform > Raw Server > File mode; add "baz=quux" to end of file but DO NOT SAVE yet.
2. On filesystem, edit 
/tmp/raw-config-test/raw-test-1.txt ; add "foo=bar" to end of file; save.
3. return to UI and save.
4. View results.


Actual results:

NOTE: This resource's configuration is currently being updated by the RHQ agent. The configuration cannot be edited until the update in progress is complete.

...which I am not sure ever seems to go away.  the conflict remains for a long time.  User never seems to be able to get back to file view.


Expected results:

Conflict should be detected; initial config update via filesystem should take place and user should be able to get back to file view.

Additional info:
Comment 1 Preethi Thomas 2010-01-07 09:16:32 EST
I retested this one 
1. $platform > Raw Server > File mode; add "baz=quux" to end of file but DO NOT
SAVE yet.
2. On filesystem, edit 
/tmp/raw-config-test/raw-test-1.txt ; add "foo=bar" to end of file; save.
3. return to UI and save.
4. View results.

Actual result

The UI edit seem to take place with no indication that file was changed.

Expected results:

Conflict should be detected; initial config update via filesystem should take
place and user should be able to get back to file view.
Comment 2 John Sanda 2010-02-09 10:50:51 EST
If you refresh the view page, then I would expect you to see the edit made directly on the file system. If however you attempt to save without refreshing the page, then I think ConfigurationManagerBean needs to have the necessary logic to determine that you are not updating the latest configuration at which point it should throw an exception so that the UI can display an appropriate message to the user.
Comment 3 wes hayutin 2010-02-16 11:54:56 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 12:00:12 EST
making sure we're not missing any bugs in rhq_triage
Comment 5 Corey Welton 2010-12-16 09:06:07 EST
Closing per triage

Note You need to log in before you can comment on or make changes to this bug.