Bug 538142 - Cannot populate more than one RHN Content Provider
Cannot populate more than one RHN Content Provider
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Content (Show other bugs)
unspecified
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Charles Crouch
Sunil Kondkar
sprint_2
: SubBug
Depends On:
Blocks: rhq_spearhead rhq_core_next
  Show dependency treegraph
 
Reported: 2009-11-17 13:22 EST by Corey Welton
Modified: 2015-02-01 18:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 13:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2009-11-17 13:22:53 EST
Description of problem:
If user creates one RHN CP and attempts to create channel repos from it, user is given an appropriate channel list.   However, if user creates more than one, only the first will get populated, and subsequent ones are empty. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create an RHN CP, "My RHN Content Provider"; assure it is synced.
2. Create a second RHN CP, "My OTHER RHN Content Provider"; sync.
3. Repos > Import 
4. Click the radio button next to "My RHN Content Provider" - note population of channel data, selectable for use as repos
5. Click the radio button next to "My OTHER RHN Content Provider"; view results.
  
Actual results:
Nothing available in subsequent RHN CPs after the first.

Expected results:
Any arbitrary number of RHN CPs should be usable.

Additional info:
Comment 1 Steve Salevan 2009-11-17 14:15:00 EST
It appears that I've discovered an exception to this set of results, and we're in a bit of a boggle as to why it's happening.  Here's the (deterministic) reproducer:

1. Create an RHN CP, "Phil Collins", and add in a non-functional RHN certificate ('bork' seems to be a good entry here)
2. Attempt to add CP, it should fail with the error: Error: Failed to start adapter for [ContentSource: id=[0], name=[Phil Collins]]. Cause: org.rhq.enterprise.server.plugin.pc.content.InitializationException:java.lang.reflect.InvocationTargetException -> java.lang.reflect.InvocationTargetException:null -> org.rhq.enterprise.server.plugin.pc.content.InitializationException:Invalid 'Certificate' property -> org.jdom.input.JDOMParseException:Error on line 1: Content is not allowed in prolog. -> org.xml.sax.SAXParseException:Content is not allowed in prolog.
3. Attempt to add CP again; it should succeed
4. Create another RHN CP, "Tony Banks", and add in a functional RHN certificate
5. Attempt to add CP, it should succeed
6. A subset of all available channels appear in channel list (and this, friends, is the aforementioned boggle)
Comment 2 wes hayutin 2010-02-16 11:52:22 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 11:58:11 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Corey Welton 2010-09-13 16:02:39 EDT
ONQA -- sunil, RHN providers are not relevant for this case anymore, but please assure we can still add multiple content providers.

Note You need to log in before you can comment on or make changes to this bug.