Bug 538164 - installer changes active partition on dual-boot machine from Windows to Fedora's /boot
installer changes active partition on dual-boot machine from Windows to Fedor...
Status: CLOSED DUPLICATE of bug 533658
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 14:53 EST by Andre Robatino
Modified: 2009-11-29 16:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 17:10:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2009-11-17 14:53:30 EST
Description of problem:
I have a dual-boot Vista/Fedora machine with Grub on the MBR.  Sometimes, Vista expects its partition to be active, for example when upgrading to SP2.  AFAICT (but I may be wrong) Fedora doesn't seem to care whether its partition is active.  But the Fedora installer switches the active partition away from Windows anyway.  Here is the output of fdisk -l on F11 before doing a clean install of F12:

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x031a25b1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       10444    83886080    7  HPFS/NTFS
/dev/sda2           10444       10469      204800   83  Linux
/dev/sda3           10469       30401   160103424   8e  Linux LVM

and after:

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x031a25b1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       10444    83886080    7  HPFS/NTFS
/dev/sda2   *       10444       10469      204800   83  Linux
/dev/sda3           10469       30401   160103424   8e  Linux LVM

I believe the same thing happened when doing a clean install of F11.  Please close this bug if there is a good reason for this behavior that I'm not aware of.  However, in this case there should probably be some kind of warning in the release notes.

Version-Release number of selected component (if applicable):
anaconda-12.46-2.fc12
Comment 1 Hans de Goede 2009-11-17 17:10:23 EST
Hi,

The main reason we are doing this is for when installing
to the boot sector of a partition instead of to the mbr.

And when installing to the bootsector of a partition and assuming default
mbr boot code (*), which will boot the first active partition, is present in
the mbr, then we must set the active / bootable flag, otherwise one might very
well end up with a not bootable system.

So we could decide to not do the active flag setting when installing into the
MBR, but this is rather (x86) platform specific and the setting of the boot
flag might be necessary on other platforms with other bootloaders then grub, so things are probably best left as is.

*) as written by dos for eons and as written by parted when creating a fresh
mbr.
Comment 2 Alexei Podtelezhnikov 2009-11-29 16:47:03 EST
Fixed actually, see bug 533658
Comment 3 Andre Robatino 2009-11-29 16:55:37 EST

*** This bug has been marked as a duplicate of bug 533658 ***

Note You need to log in before you can comment on or make changes to this bug.