Bug 538193 - pybackpack does not detect external CD Burner
Summary: pybackpack does not detect external CD Burner
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pybackpack
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Miller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-17 21:26 UTC by Luya Tshimbalanga
Modified: 2010-01-03 21:04 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-01-03 21:04:28 UTC


Attachments (Terms of Use)
Failed to detect CD/DVD drive on new backup set (29.20 KB, image/png)
2009-12-17 20:46 UTC, Luya Tshimbalanga
no flags Details
Patch to add braseromedia support in the backup set editor (7.01 KB, patch)
2009-12-17 23:00 UTC, Andrew Price
no flags Details | Diff
No dvd image location to burn pointed by default (111.89 KB, image/png)
2009-12-19 21:42 UTC, Luya Tshimbalanga
no flags Details
Dialog about setting path of image file (33.19 KB, image/png)
2009-12-21 21:33 UTC, Luya Tshimbalanga
no flags Details
Patch to make brasero select pybackpack.iso by default (411 bytes, patch)
2009-12-21 22:33 UTC, Andrew Price
no flags Details | Diff

Description Luya Tshimbalanga 2009-11-17 21:26:31 UTC
Description of problem:
pybackpack will not detect external USD CD/DVD burner because of missing python module (possibly nautilus-cd-burner not available on Fedora 12)

Version-Release number of selected component (if applicable):
0.5.6-5

How reproducible:
Always

Steps to Reproduce:
1. Simply start pybackpack and follow instructing
2.
3.
  
Actual results:
"No CD burner available, because you don't have python mod"

Expected results:
External DVD burner should be recognized and used.

Additional info:

Comment 1 Andrew Price 2009-11-18 16:58:14 UTC
Yes this is due to the nautilusburn module being removed before the brasero python bindings became mature enough to replace it. I'll fix this upstream eventually but it's way down on my list of priorities at the moment. Migrate-pybackpack-to-brasero patches welcome if anyone cares enough.

Comment 2 Andrew Price 2009-11-28 03:41:58 UTC
I have just committed this changeset to replace nautilusburn with
brasero upstream:

http://projects.sucs.org/projects/pybackpack/changeset/231

I've looked into backporting those changes to 0.5.6 (which is currently
in Fedora) but it would be painful and I really don't want to do it. I
would ideally like to get a 0.5.6+svn231 or 0.5.7 package uploaded soon,
but there have been a lot of changes since 0.5.6.

Comment 3 Luya Tshimbalanga 2009-11-28 20:55:20 UTC
(In reply to comment #2)
> I have just committed this changeset to replace nautilusburn with
> brasero upstream:
> 
> http://projects.sucs.org/projects/pybackpack/changeset/231

Line 527 and line 738. Are those dialog integrated in braseroburn?

Comment 4 Andrew Price 2009-11-29 02:12:18 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > http://projects.sucs.org/projects/pybackpack/changeset/231
> 
> Line 527 and line 738. Are those dialog integrated in braseroburn?  

Obsoleted by it, yes.

Comment 5 Adam Miller 2009-12-16 21:06:11 UTC
Please install the new pybackpack proposed update package from koji and test, if this fixes it then I will push the package to updates as a solution to this bug.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1875808

Comment 6 Luya Tshimbalanga 2009-12-17 20:46:47 UTC
Created attachment 379090 [details]
Failed to detect CD/DVD drive on new backup set

Running pybackpack from koji. Backing up the entire home folder to CD/DVD successfully worked. Unfortunately, that function is not available should an user create own back up set as seen on attached picture. Test in done on both desktop and laptop.

Comment 7 Luya Tshimbalanga 2009-12-17 20:48:44 UTC
To clarify, the test failed even though CD/DVD is available from custom backup.

Comment 8 Andrew Price 2009-12-17 23:00:58 UTC
Created attachment 379116 [details]
Patch to add braseromedia support in the backup set editor

It turns out I hadn't completely eradicated the nautilusburn usage and missed seteditor.{py,glade} completely. D'oh.

Adam - I'm attaching a quick-and-dirty patch which I've just committed to pybackpack's svn repository (r238). It ain't pretty but it should fix Luya's problem. If you can carry this in your rpm I'll make sure the next release includes it.

Luya - thanks for testing!

Comment 9 Adam Miller 2009-12-18 19:39:41 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=1879830

New build with the patch. If this works out, I will submit it to updates-testing for Fedora 12.

-Adam

Comment 10 Luya Tshimbalanga 2009-12-19 21:42:17 UTC
Created attachment 379399 [details]
No dvd image location to burn pointed by default

Good work. This patch fixed braseromedia support in backup set editor. On small detail is the created disc image is not automatically selected from its path which can confuse users (see attached image). I had to manually search it on /tmp.

Comment 11 Andrew Price 2009-12-20 14:37:30 UTC
Hm, I can't reproduce that behaviour here. I wonder if it's a bug in python-brasero. Could you grab the example script from here:

 http://git.gnome.org/browse/gnome-python-desktop/plain/examples/braseroburn/write-image.py

run it like 'python write-image.py foo.iso' and check if the dialog which appears has foo.iso selected or if it looks like in your screenshot?

Comment 12 Luya Tshimbalanga 2009-12-21 21:33:45 UTC
Created attachment 379715 [details]
Dialog about setting path of image file

The dialog has iso file selected. Maybe the bug is somewhere else.

Comment 13 Andrew Price 2009-12-21 22:33:08 UTC
Created attachment 379725 [details]
Patch to make brasero select pybackpack.iso by default

OK, I think I've figured it out now. Here's a one-liner which should fix that problem (r239). Thanks again.

Comment 14 Adam Miller 2009-12-22 17:42:22 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=1886543

New build with both patches. Feedback welcome :)

Comment 15 Luya Tshimbalanga 2009-12-22 20:24:27 UTC
Testing the new build, all issues are resolved.

Comment 16 Adam Miller 2009-12-22 21:16:54 UTC
submitting to updates-testing.

Comment 17 Fedora Update System 2009-12-22 21:19:21 UTC
pybackpack-0.5.7-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pybackpack-0.5.7-3.fc12

Comment 18 Fedora Update System 2009-12-23 21:31:12 UTC
pybackpack-0.5.7-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pybackpack'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13570

Comment 19 Fedora Update System 2010-01-03 21:04:23 UTC
pybackpack-0.5.7-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.