Bug 538261 - "Sending your profile will enable a monthly update" -- not clear
"Sending your profile will enable a monthly update" -- not clear
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 21:51 EST by Denny Crane
Modified: 2010-01-25 14:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 14:34:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Denny Crane 2009-11-17 21:51:06 EST
Description of problem:
On the Hardware Profile page, the following text is not clear:
"Sending your profile will enable a monthly update"

1) Potential confusion regarding what "updates" is even referring to. When I first started installing Fedora (8), I was not sure if this meant that I had to send my hardware profile if I wanted to have access to Fedora updates. I later asked about this in the forums and was told that it actually meant that the hardware profile "updates" (i.e. updates on your hardware profile) would be sent each month.

Soooo ... firstly, my suggestion is that this text should be modified to make it clear that is what it means. Such as: "If you agree to send your profile now, you will also enable a feature whereby your hardware profile is resent (including any new details) on a monthly basis."

2) Once I was aware of what the text in question above actually meant, I have always been hesitant to send my profile. It just so happens that I would actually LIKE to send my profile when installing Fedora ... but I DO NOT want my computer communicating with regards to this on an ongoing basis. To me, that seems like a waste of resources and perhaps pries too much into my privacy.

Soooo ... it is my suggestion that there should be an option to send only once, because you might actually get more users to cooperate if you do!


Version-Release number of selected component (if applicable):
1.110-1 / Fedora 12

How reproducible:
100%

Steps to Reproduce:
1.Run firstboot
2.Navigate to Hardware Profile screen
3.Observe
  
Actual results:
Unclear text and lack of one-time option.

Expected results:
Clear text and option to send hardware profile only once.

Additional info:
Comment 1 Chris Lumens 2009-11-18 08:57:31 EST
This firstboot page is provided by smolt, so this bug should be assigned to that component.
Comment 2 Mike McGrath 2010-01-25 14:34:16 EST
Smolt is designed to prune stale profiles.  This is done for a number of reasons including removing duplicates over time and being able to properly track what the current hardware environment looks like instead of what it looks like now + what it looked like 2 or 3 years ago.

Having the regular check-ins is important for a number of reasons.  We want to encourage the regular check-in.  The submit only once is certainly easy to do after firstboot if the users chose no.

I'll change the word "updates" to checkin though.

Note You need to log in before you can comment on or make changes to this bug.