This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 538271 - Nothing left to boot after F12 deactivated Windows partition
Nothing left to boot after F12 deactivated Windows partition
Status: CLOSED DUPLICATE of bug 533658
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 23:19 EST by Alexei Podtelezhnikov
Modified: 2009-11-30 05:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 09:24:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2009-11-17 23:19:42 EST
This is god damn fucking lovely!

I specifically selected NOT to install bootloader into MBR, which
I wanted to keep for NTLDR. Apparently, F12-LiveCD-KDE installer
just erased it anyhow. I did put GRUB on the /boot partition.

How the fuck am I supposed to boot now? 
How can I recover NTLDR?
Comment 1 Chris Lumens 2009-11-18 09:24:07 EST
That kind of language will get you nowhere with us.

*** This bug has been marked as a duplicate of bug 504570 ***
Comment 2 Alexei Podtelezhnikov 2009-11-21 20:21:08 EST
I apologize, but it took me a while to figure out what happened
and frustration was overwhelming.

So this is what actually transpired:

sda(MBR) contains Dell loader which passes to
   *sda2* boot sector was *active* originally, and used by NTLDR,
          and configured to load GRUB and Fedora if selected
    sda5  boot sector is where I put GRUB bootloader

After installation Anaconda *deactivated* sda2
and I could not reach any bootable OS.

Proposed solution:
Leave active partitions alone if user puts bootloader on a partition,
but warn that it's his responsibility to configure ALL bootloaders if he 
wants to reach /boot.
Comment 3 Alexei Podtelezhnikov 2009-11-29 16:47:39 EST
Fixed actually, see bug 533658
Comment 4 Hans de Goede 2009-11-30 05:12:58 EST

*** This bug has been marked as a duplicate of bug 533658 ***

Note You need to log in before you can comment on or make changes to this bug.