Bug 538379 - segmentation fault in mowgli_dictionary_retune
Summary: segmentation fault in mowgli_dictionary_retune
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL: http://jira.atheme.org/browse/AUD-96
Whiteboard: abrt_hash:51f2e47d525f96b37648c0bd9b6...
: 538702 556174 557697 563633 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-18 12:47 UTC by drewskiwooskie
Modified: 2010-03-09 14:07 UTC (History)
6 users (show)

Fixed In Version: 0.4-1.fc12.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-02 01:10:22 UTC


Attachments (Terms of Use)
File: backtrace (26.03 KB, text/plain)
2009-11-18 12:47 UTC, drewskiwooskie
no flags Details
Terminal output from audacious-2.1-5.fc12.1.x86_64 (8.88 KB, text/plain)
2009-11-19 18:27 UTC, Michael Hampton
no flags Details
Terminal output from audacious-2.1-5.fc12.2.x86_64 (7.79 KB, text/plain)
2009-11-19 18:32 UTC, Michael Hampton
no flags Details

Description drewskiwooskie 2009-11-18 12:47:35 UTC
abrt detected a crash.

Attached file: backtrace
cmdline: audacious2
component: audacious
executable: /usr/bin/audacious2
kernel: 2.6.31.5-127.fc12.x86_64
package: audacious-2.1-5.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 drewskiwooskie 2009-11-18 12:47:39 UTC
Created attachment 370069 [details]
File: backtrace

Comment 2 Michael Schwendt 2009-11-18 20:57:39 UTC
Can you please add some details on reproducibility?

It's a segfault in libmowgli, though may be caused by Audacious. At first sight, the "dda://" dictionary key is supicious. Truncated cdda://?

Comment 3 Michael Schwendt 2009-11-19 11:05:25 UTC
*** Bug 538702 has been marked as a duplicate of this bug. ***

Comment 4 Michael Hampton 2009-11-19 17:49:23 UTC
I think this is going to be one of those intermittent ones.

When I load up a playlist, ("Load List") audacious freezes for about 25-30 seconds. Then, it either crashes, or I get lucky and it comes back, and I get to play the playlist. Interestingly, even if audacious does crash, when I restart it, the playlist is loaded.

Comment 5 Michael Schwendt 2009-11-19 18:10:26 UTC
Well, two people with x86_64 have had it crash already. :)  So, surely there is something wrong. Heap corruption, for example, can cause weird results.

[...]

The "freeze" is due to downloading/prebuffering network stream data in a non-threaded way, which is room for improvement for future releases of Audacious.

[...]

Could be interesting to get terminal output from these two test-builds for such a crash. You would need to download the "audacious-libs" and "audacious" packages and "rpm -Uvh ..." them at once:

1) http://koji.fedoraproject.org/koji/taskinfo?taskID=1817031

2) http://koji.fedoraproject.org/koji/taskinfo?taskID=1817043

Comment 6 Michael Hampton 2009-11-19 18:27:26 UTC
Created attachment 372307 [details]
Terminal output from audacious-2.1-5.fc12.1.x86_64

Comment 7 Michael Hampton 2009-11-19 18:32:21 UTC
Created attachment 372310 [details]
Terminal output from audacious-2.1-5.fc12.2.x86_64

Both of these act the same way: long freezes while loading the playlist, but no crash.

Comment 8 Michael Schwendt 2009-11-19 18:54:36 UTC
Keep trying. :)  As long as it there is no crash, the output looks normal and expected. Only if you can reproduce the crash, the output might reveal interesting details.

In case these test-builds don't crash anymore in the same way, perhaps the 2.1-5 build for x86_64 from koji is faulty? Built on Sep 21st. Hmmm... how likely is that? 

[...]

There's some background in the upstream ticket ( http://jira.atheme.org/browse/AUD-96 ). Out-of-memory would be the obvious reason for such a crash in that area of the code. I think in the meantime I'll release an official test-update/rebuild for F-12 with a safety-check that would prevent the crash condition and print a debug message to the console instead.

Comment 9 Michael Schwendt 2009-12-20 13:49:39 UTC
Just for the record, a very similar crash in Audacious 1.5.1 (and later) was reported for Ubuntu on 2008-09-24 (!) already,

  https://bugs.launchpad.net/ubuntu/+source/audacious/+bug/273908
  (especially note comment 5)

and confirmed for later Ubuntu releases.

[...]

If the same crash is reproducible with the 2.1-7 build on Fedora 12 or Audacious 2.2 (currently in Fedora 13 development only), please add a comment.

Comment 10 Michael Hampton 2009-12-20 13:57:09 UTC
On F11 this was an issue, but I installed F12 on day of release and this issue hasn't occurred yet.

(I also traced the long delay to audacious trying to connect to each of the 22 streams in the playlist before returning from the add dialog, but that's another issue entirely.)

Comment 11 Michael Schwendt 2009-12-20 14:11:17 UTC
This ticket was reported for F12, though. ;)  Mission objective is to find out whether it's some sort of memory corruption that is will _still_ be lurking also in Audacious 2.2 (or later). Upstream indicates that it _might_ be fixed as a result of rewrites in the Audacious 2.2 code base. But who knows...?

Comment 12 Michael Hampton 2009-12-20 14:15:40 UTC
You're quite right; I was mis-remembering. I have had this crash on F12 (and F11; I remember it annoying me for months). But not recently. My current version is audacious-2.1-7.fc12.x86_64

Comment 13 Fedora Update System 2010-01-01 12:44:18 UTC
audacious-plugin-fc-0.4-1.fc12.2,audacious-plugins-2.2-7.fc12,audacious-2.2-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/audacious-plugin-fc-0.4-1.fc12.2,audacious-plugins-2.2-7.fc12,audacious-2.2-4.fc12

Comment 14 Fedora Update System 2010-01-02 03:33:14 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-7.fc12, audacious-2.2-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 15 Fedora Update System 2010-01-05 22:54:10 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-8.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 16 Fedora Update System 2010-01-12 23:30:42 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 17 Fedora Update System 2010-01-12 23:31:38 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 18 Fedora Update System 2010-01-12 23:32:30 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 19 Michael Schwendt 2010-01-16 23:02:05 UTC
*** Bug 556174 has been marked as a duplicate of this bug. ***

Comment 20 Michael Schwendt 2010-01-22 09:33:07 UTC
*** Bug 557697 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2010-01-26 00:57:52 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-7.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 22 Michael Schwendt 2010-01-27 10:41:35 UTC
Third-party add-on packages for Audacious 2.2 are available
in their respective -updates-testing repository.

Please give feedback on the Audacious 2.2 test update:
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

There are no plans to continue with Audacious 2.1.

Comment 23 Fedora Update System 2010-02-01 01:24:02 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-10.fc12.pl14, audacious-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 24 Fedora Update System 2010-02-02 01:09:22 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-10.fc12.pl14, audacious-2.2-10.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Michael Schwendt 2010-02-09 11:34:49 UTC
Did you use the "scrobbler" plugin?

Comment 26 Michael Schwendt 2010-02-10 20:08:58 UTC
*** Bug 563633 has been marked as a duplicate of this bug. ***

Comment 27 drewskiwooskie 2010-02-12 16:04:34 UTC
Wow, I did not think that people actually looked at this or bugs I filed with the automated bug tool. This is absolutely fantastic and from now on if I use the automatic bug reporting tool I will check and give feedback etc, a.k.a. be a part of the community :) and I apologize for not doing so earlier I feel like a jerk.
Yes , I did use the scrobbler plugin for audacious.

Comment 28 Michael Schwendt 2010-02-12 17:50:38 UTC
Please see: http://jira.atheme.org/browse/AUDPLUG-179

Comment 29 drewskiwooskie 2010-02-12 17:58:15 UTC
excellent, thank you, I will disable the plugin as well until it gets fixed.

Comment 30 Michael Schwendt 2010-02-15 14:08:54 UTC
To Scrobbler users:

https://admin.fedoraproject.org/updates/audacious-plugins-2.2-23.fc12

Comment 31 drewskiwooskie 2010-02-16 13:27:21 UTC
Upgraded to audacious-plugins-2.2-23.fc12   
Seems like scrobbler+stream browser plugin is  causing it to crash.
If I don't use stream browser it works fine. 
backtrace: http://pastebin.com/m1c172c1d

Comment 32 Michael Schwendt 2010-02-16 15:46:27 UTC
Can you regenerate that backtrace after installing the missing -debuginfo packages? Most likely an upgrade of audacious-plugins-debuginfo to 2.2-23.fc12 will suffice.

The streambrowser implementation is inherently susceptible to race conditions. I've added a patch to work around one such problem in -21.fc12 already, but that doesn't fix the entire implementation, which is broken by design.

Comment 33 drewskiwooskie 2010-02-16 18:32:52 UTC
I accidentally deleted that backtrace. I have installed the debuginfo for 2.2-23 and will post a new backtrace if it crashes again. so far it has behaved well since the last crash I posted.

Comment 34 drewskiwooskie 2010-03-09 14:07:40 UTC
this has not crashed at all since. Things have been working great. Bug has probably been fixed.


Note You need to log in before you can comment on or make changes to this bug.