Bug 538425 - Wrong milter.conf file template in clamav-milter
Summary: Wrong milter.conf file template in clamav-milter
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: clamav
Version: el5
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-18 14:58 UTC by Alexandr A. Panko
Modified: 2011-04-06 22:53 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-03-26 18:58:44 UTC


Attachments (Terms of Use)

Description Alexandr A. Panko 2009-11-18 14:58:47 UTC
Description of problem:
clamav-milter rpm package contains milter.conf file wich is really clamd.conf file...
As a result milter work on default config values.

Version-Release number of selected component (if applicable):
clamav-milter-0.95.1-1.el5

How reproducible:


Steps to Reproduce:
1. Look into contents of clamav-milter or install it and compare /etc/clamd.d/milter.conf with real milter template from sources dir /usr/src/redhat/BUILD/clamav-0.95.1/etc/clamav-milter.conf
  
Actual results:
Wrong configuration file template

Expected results:
Right configuration file template

Additional info:
Line 352 of clamav.spec creates milter.conf from clamd.conf which is wrong.
Line 361 of clamav.spec just removes $RPM_BUILD_ROOT%_sysconfdir/clamav-milter.conf

Comment 1 Fedora Update System 2011-03-04 01:52:58 UTC
Package clamav-0.97-3.el4:
* should fix your issue,
* was pushed to the Fedora EPEL 4 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing clamav-0.97-3.el4'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/clamav-0.97-3.el4
then log in and leave karma (feedback).

Comment 2 Fedora Update System 2011-03-04 05:54:18 UTC
clamav-0.97-3.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clamav'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/clamav-0.97-3.el4

Comment 3 Alexandr A. Panko 2011-03-04 08:08:44 UTC
Thank you for feedback.

It was very long ago, and it is not interesting now.
I switched to EPEL and all was fine since then.

So this report may be closed (not see proper choice here to close it by myself).

Comment 4 Fedora Update System 2011-03-13 21:27:02 UTC
clamav-0.97-4.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/clamav-0.97-4.el4

Comment 5 Fedora Update System 2011-03-15 14:36:36 UTC
clamav-0.97-9.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clamav-0.97-9.el6

Comment 6 Fedora Update System 2011-03-15 14:37:41 UTC
clamav-0.97-9.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/clamav-0.97-9.el4

Comment 7 Fedora Update System 2011-03-15 14:38:13 UTC
clamav-0.97-9.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/clamav-0.97-9.el5

Comment 8 Fedora Update System 2011-03-18 09:11:46 UTC
clamav-0.97-11.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clamav-0.97-11.el6

Comment 9 Fedora Update System 2011-03-18 09:12:34 UTC
clamav-0.97-11.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/clamav-0.97-11.el5

Comment 10 Fedora Update System 2011-03-18 09:13:18 UTC
clamav-0.97-11.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/clamav-0.97-11.el4

Comment 11 Fedora Update System 2011-03-26 18:57:37 UTC
clamav-0.97-11.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-26 19:00:10 UTC
clamav-0.97-11.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-03-30 10:47:16 UTC
clamav-0.97-12.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clamav-0.97-12.el6

Comment 14 Fedora Update System 2011-03-30 10:48:07 UTC
clamav-0.97-12.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/clamav-0.97-12.el4

Comment 15 Fedora Update System 2011-03-30 10:48:55 UTC
clamav-0.97-12.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/clamav-0.97-12.el5

Comment 16 Fedora Update System 2011-04-06 22:52:32 UTC
clamav-0.97-12.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.