Bug 53847 - man page misleading
Summary: man page misleading
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-19 19:43 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-19 19:43:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-09-19 19:43:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010915

Description of problem:
The man page is misleading, with respect to the --target option, and
--rebuild/--recompile.

It isn't entirely clear from the man page that the --target option applies
to the --rebuild/--recompile commands.  This is compounded by the fact that
i.e., '--target i686' doesn't work; you need to have an '=', and say
'--target=i686'.  I realize for this seems minor, but what ends up
happening for those using source rpms for the first time is this:

1) Want to build athlon rpm
2) Look at man page, it doesn't seem that --target works with --rebuild,
but let's try
3) Try 'rpm --rebuild --target athlon foo.src.rpm'
4) Oh, doesn't work.  I guess --target doesn't apply to --rebuild.
5) Redo using -i followed by -ba etc...

When really, it should have been --target=athlon

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
man rpm

	

Additional info:

Comment 1 Jeff Johnson 2001-09-20 05:19:21 UTC
This works for me in rpm-4.0.3-1.05.

You do need to do "--target athlon",
not "--target=athlon" if invoking
from rpm due to limitations imposed by
popt. Invoke as rpmbuild if you want
it either way.


Note You need to log in before you can comment on or make changes to this bug.