Bug 538494 - setkey_t fails to request module load for af_key
Summary: setkey_t fails to request module load for af_key
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-18 17:25 UTC by Joshua Roys
Modified: 2009-12-02 04:37 UTC (History)
3 users (show)

Fixed In Version: 3.6.32-49.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 16:40:25 UTC


Attachments (Terms of Use)

Description Joshua Roys 2009-11-18 17:25:24 UTC
Description of problem:
avc: denied { module_request } ...

Version-Release number of selected component (if applicable):
3.6.32-41.fc12

How reproducible:
try to run setkey/racoon without af_key loaded

Actual results:
avc, racoon says protocol not available

Expected results:
working ipsec

Additional info:
Please add
 kernel_request_load_module(setkey_t)
to policy.  Thanks.

Comment 1 Daniel Walsh 2009-11-18 18:15:34 UTC
Did you turn off ipv6?

Comment 2 Joshua Roys 2009-11-18 18:55:45 UTC
Yes, we do:

echo "install ipv6 /bin/true" >> /etc/modprobe.d/ipv6blacklist.conf
echo "install sit /bin/true" >> /etc/modprobe.d/ipv6blacklist.conf
echo "install tunnel4 /bin/true" >> /etc/modprobe.d/ipv6blacklist.conf

echo "blacklist ipv6" > /etc/modprobe.d/ipv6blacklist.conf

Comment 3 Daniel Walsh 2009-11-18 20:01:12 UTC

*** This bug has been marked as a duplicate of bug 527936 ***

Comment 4 Daniel Walsh 2009-11-18 21:16:51 UTC
You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.6.32-47.fc12.noarch

Comment 5 Fedora Update System 2009-11-23 23:36:09 UTC
selinux-policy-3.6.32-49.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-49.fc12

Comment 6 Fedora Update System 2009-11-25 15:19:04 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12131

Comment 7 Fedora Update System 2009-12-02 04:30:44 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.