Bug 53850 - Unable to remove logrotate package due to dependancy from sysklogd
Summary: Unable to remove logrotate package due to dependancy from sysklogd
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sysklogd   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-19 20:34 UTC by Ben LaHaise
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 04:28:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben LaHaise 2001-09-19 20:34:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10smp i686)

Description of problem:
Unable to remove logrotate package due to dependancy from sysklogd.  This
happens in all recent versions of RHL, including the 7.2 betas.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -e logrotate on any recent version of Red Hat Linux
	

Actual Results:  [root@toomuch root]# rpm -e logrotate
error: removing these packages would break dependencies:
        logrotate >= 3.5.2 is needed by sysklogd-1.4.1-4
[root@toomuch root]# 


Expected Results:  the logrotate package should be deleted.

Additional info:

It looks like sysklogd depends on logrotate for /etc/logrotate.d.  I think
we should just allow rpm to handle the creation/removal of the directory,
or make it part of the filesystem package.

Comment 1 Bill Nottingham 2002-03-12 21:32:41 UTC
Fixed in 1.4.1rh-5.

Comment 2 Bill Nottingham 2002-03-12 21:33:43 UTC
make that -6.


Note You need to log in before you can comment on or make changes to this bug.