Bug 53852 - RFE: add /sbin/restore to rescue mode
RFE: add /sbin/restore to rescue mode
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-19 17:18 EDT by ross tyler
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ross tyler 2001-09-19 17:18:22 EDT
Description of Problem:

the bootable CD seawolf-i386-disc1 may be booted in rescue mode to recover
a damaged system.

my disaster recovery plan involves nightly dump's of all file systems to
tape.
i have placed a .recover.d directory in the first file system (/) that
contains scripts that can be invoked to perform a complete recovery from
the tape image.
this includes

partitioning the disk
creating the file systems
restore'ing the file systems
lilo'ing the disk

the intent is to boot off the rescue CD, restore the .recover.d directory
and execute the recover script found there.

unfortunately, the rescue CD does not include the restore program!
it is part of the dump rpm but this rpm is on disc2 and i can't umount
disc1 to get it.
my only work around is to get it from another linux box by network or
floppy.

rcp work ok but ftp does not.

once i have restore i can get everything else i need from .recover.d.
note: i have put lilo and sfdisk in my .recover.d because they are also not
on the rescue CD.

the rescue disc1 should have /sbin/restore

it would be nice if the rescue disc also had sfdisk and lilo.
it would be nice if the ftp client on the rescue disk worked.

Version-Release number of selected component (if applicable):

7.1 seawolf-i386-disc1

How Reproducible:

see above

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Brent Fox 2001-09-20 11:32:34 EDT
Marking as a request for enhancement.
Comment 2 ross tyler 2001-09-25 14:55:04 EDT
the cd should also have the scsi tape module suitable for this kernel so that a
local tape drive might be used.

i have found that a copy of the st.o module from
/lib/modules/2.4.2-2/kernel/drivers/scsi/st.o will not work with the kernel on
the install cd (unresolved references).

without this module a local tape drive cannot be used for disaster recovery.
the only way to read a tape, in this case, is to read it across the network.
Comment 3 Michael Fulbright 2001-09-27 12:23:08 EDT
Related to bug 3383.
Comment 4 Michael Fulbright 2001-09-27 12:23:46 EDT
Will consider for future release.
Comment 5 Michael Fulbright 2002-03-26 12:27:21 EST
Deferred to future release.
Comment 6 Red Hat Bugzilla 2006-02-21 13:48:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.