Bug 538527 - libvirt fails to allow attachment of iso file on samba share
libvirt fails to allow attachment of iso file on samba share
Status: CLOSED DUPLICATE of bug 517304
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-18 13:42 EST by Rubin Simons
Modified: 2009-11-19 08:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 08:13:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rubin Simons 2009-11-18 13:42:58 EST
Description of problem:
libvirt fails to allow the (temporary) connection of a .iso file
which exists on a samba share to a newly created virtual machine.
It complains about not being able to set permissions.

Because of this, it is not possible to install a new virtual
machine with an OS without copying the iso file to your desktop,
and chmod/chowning the file to what libvirt/qemu expects. This 
is extremely unworkable when you have lots of iso files on a
centralized system.

Since the iso file is not to be considered a part of the emulated
system, I fail to understand why it even tries to chown/chmod the
iso file. It should leave the iso file for what it is. This worked
correctly in Fedora 11.

Version-Release number of selected component (if applicable):
libvirt-0.7.1-15.fc12.x86_64
libvirt-client-0.7.1-15.fc12.x86_64
libvirt-python-0.7.1-15.fc12.x86_64
qemu-kvm-0.11.0-11.fc12.x86_64

How reproducible:
Always. Just have a .iso file on a samba share and try to attach it.

Steps to Reproduce:
1. Create new VM.
2. Try to attach iso on samba share
3. Observe error.
  
Actual results:
[rubin@inden qemu]$ sudo virsh start bomans
error: Failed to start domain bomans
error: internal error unable to start guest: libvir: QEMU error : cannot set ownership on /net/Software/Fedora 12/Fedora-12-x86_64-DVD.iso: Permission denied

Expected results:
Correctly attached iso file to the VM so as to allow installation!

Additional info:
N/A.
Comment 1 Rubin Simons 2009-11-18 13:44:57 EST
Added myself to CC list.
Comment 2 Mark McLoughlin 2009-11-19 08:13:58 EST
Thanks for the report

This sounds very similar to bug #517304, so I'm going to mark it as a dup of that even though it's about NFS

*** This bug has been marked as a duplicate of bug 517304 ***

Note You need to log in before you can comment on or make changes to this bug.