Bug 538533 - [abrt] crash detected in wallpapoz-0.4.1-11.svn92_trunk.fc12
Summary: [abrt] crash detected in wallpapoz-0.4.1-11.svn92_trunk.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wallpapoz
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d8df453a
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-18 18:50 UTC by amdepass
Modified: 2010-02-18 22:29 UTC (History)
25 users (show)

Fixed In Version: wallpapoz-0.4.1-15.svn92_trunk.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-18 22:19:46 UTC


Attachments (Terms of Use)
File: backtrace (577 bytes, text/plain)
2009-11-18 18:50 UTC, amdepass
no flags Details
My wallpapoz (609 bytes, text/xml)
2009-11-24 14:37 UTC, Nikolay Bryskin
no flags Details

Description amdepass 2009-11-18 18:50:25 UTC
abrt detected a crash.

Attached file: backtrace
cmdline: python /usr/libexec/daemon_wallpapoz 
component: wallpapoz
executable: /usr/libexec/daemon_wallpapoz
kernel: 2.6.31.5-127.fc12.i686.PAE
package: wallpapoz-0.4.1-11.svn92_trunk.fc12
uuid: d8df453a

Comment 1 amdepass 2009-11-18 18:50:28 UTC
Created attachment 370162 [details]
File: backtrace

Comment 2 Mamoru TASAKA 2009-11-20 01:11:11 UTC
Well,

* Would you tell me the procedure how you can reproduce this
  bug in details?
* Please attach (not copy and paste) your ~/.wallpapoz/wallpapoz.xml
* Would you tell me the following?
  - What desktop environment you are using
  - How many workspace you have
  - If any desktop effect (like compiz) is enabled or not
* Would you tell me what the following returns when the bug 
  occurs?
--------------------------------------------------------
$ xprop -root _NET_DESKTOP_VIEWPORT
$ xprop -root _NET_DESKTOP_GEOMETRY
$ xwininfo -root
--------------------------------------------------------

Comment 3 Nikolay Bryskin 2009-11-24 14:36:15 UTC
I have the same crash.
I'm using Gnome desktop, have 4 workspaces and compiz is enabled.

Comment 4 Nikolay Bryskin 2009-11-24 14:37:02 UTC
Created attachment 373442 [details]
My wallpapoz

Comment 5 Nikolay Bryskin 2009-11-24 14:37:41 UTC
[nbryskin@dev-nbryskin-linux ~]$ xprop -root _NET_DESKTOP_VIEWPORT
_NET_DESKTOP_VIEWPORT(CARDINAL) = 0, 0
[nbryskin@dev-nbryskin-linux ~]$ xprop -root _NET_DESKTOP_GEOMETRY
_NET_DESKTOP_GEOMETRY(CARDINAL) = 7680, 1200
[nbryskin@dev-nbryskin-linux ~]$ xwininfo -root

xwininfo: Window id: 0x337 (the root window) (has no name)

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1920
  Height: 1200
  Depth: 24
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -0+0  -0-0  +0-0
  -geometry 1920x1200+0+0

Comment 6 Mamoru TASAKA 2009-11-24 15:37:05 UTC
(In reply to comment #3)
> I have the same crash.
> I'm using Gnome desktop, have 4 workspaces and compiz is enabled.  

Well, it is unclear in what sense you are saying you have
the "same" crash. The fact that "wallpapoz crashes" does not mean
that the reporter and you are seeing the same issue.
Even if you got the same backtrace as in comment 1, still it does
not mean that you and the reporter are seeing the same issue.
Please file another bug report.

Still setting needinfo from the reporter. amdepass, would
you tell me what is happening on your desktop?

Comment 7 Nikolay Bryskin 2009-11-25 07:25:47 UTC
abrt points to this bug when it catches this crash, so how should I create another bug report using abrt?

Comment 8 Mamoru TASAKA 2009-11-25 14:53:07 UTC
For now I can only tell that if the bug can be detected without running
abrt and the bug can be reproducible it is much better.... (I don't know
well how abrt works and I have never used abrt)

Comment 9 Mamoru TASAKA 2010-01-18 14:08:00 UTC
Once closing due to no additional information from the
reporter.

Comment 10 Mamoru TASAKA 2010-02-03 19:45:15 UTC
Reopening as this is now reproducible to me.

Comment 11 Fedora Update System 2010-02-03 20:30:39 UTC
wallpapoz-0.4.1-12.svn92_trunk.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-12.svn92_trunk.fc12

Comment 12 Fedora Update System 2010-02-03 20:31:07 UTC
wallpapoz-0.4.1-12.svn92_trunk.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-12.svn92_trunk.fc11

Comment 13 Fedora Update System 2010-02-05 01:39:21 UTC
wallpapoz-0.4.1-12.svn92_trunk.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wallpapoz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1483

Comment 14 Fedora Update System 2010-02-08 18:56:37 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-15.svn92_trunk.fc12

Comment 15 Fedora Update System 2010-02-08 18:58:14 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-15.svn92_trunk.fc11

Comment 16 Fedora Update System 2010-02-09 21:01:04 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wallpapoz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1687

Comment 17 Fedora Update System 2010-02-18 22:19:04 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-02-18 22:29:42 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.