Bug 538584 - preupgrade is not smart enough to realize /boot is too small for installed kernel to fit
preupgrade is not smart enough to realize /boot is too small for installed ke...
Status: CLOSED DUPLICATE of bug 530541
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-18 16:06 EST by Alex Chernyakhovsky
Modified: 2014-01-21 18:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 11:22:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Chernyakhovsky 2009-11-18 16:06:16 EST
Description of problem:
Fedora's preupgrade tool utilizes /boot utilizes over 100MB of space, and dutifully makes sure /boot can hold the preupgrade package. However, preupgrade fails to take into account how much space the to-be-installed kernel will take, which results in anaconda complaining that "/boot needs 16MB more space" to continue the installation

Version-Release number of selected component (if applicable):
Fedora 11 preupgrade preupgrade-1.1.2-1.fc11.noarch.rpm

How reproducible:
Every time

Steps to Reproduce:
1. Using a computer with a 200MB /boot (Fedora standard), run preupgrade when there are old kernels still installed from previous updates
2.
3.
  
Actual results:
Preupgrade installs itself, resulting in an anaconda error that has to be manually fixed.

Expected results:
Preupgrade realizes that /boot is too small, and either removes old kernels, warns the user, or similar.

Additional info:
Comment 1 Will Woods 2009-11-19 11:22:21 EST
preupgrade-1.1.3, in updates-testing, checks the size of /boot. 

Please test it and provide feedback here:
F11: https://admin.fedoraproject.org/updates/F11/FEDORA-2009-11547
F10: https://admin.fedoraproject.org/updates/F10/FEDORA-2009-11530

*** This bug has been marked as a duplicate of bug 530541 ***

Note You need to log in before you can comment on or make changes to this bug.