Bug 53860 - Matrox HAL module isn't supported
Matrox HAL module isn't supported
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-20 04:28 EDT by Dmitry Bolkhovityanov
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-03 02:13:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dmitry Bolkhovityanov 2001-09-20 04:28:39 EDT
Description of Problem:

The .spec file contains a line "UseMatroxHal NO", which disables ability to
use Matrox's mga_hal_drv.o module.

Unfortunately, HAL module is *required* if one needs to use more than one
G450 (e.g. G450AGP+G450PCI) or 2nd head of G400. (See
http://www.xfree86.org/pipermail/xpert/2001-September/011381.html for
details of testing on Red Hat's 4.0.3, and 4.1 gives the same results.)

What's so bad in the HAL module?  Sure, it slows down X startup, but since
Red Hat doesn't ship mga_hal_drv.o itself, "UseMatroxHal YES" is harmless. 
Otherwise those who know what they are doing have to replace the driver
itself (mga_drv.o).  I see no reason for it.

Version-Release number of selected component (if applicable):
4.1.0-3

How Reproducible:
100%
Comment 1 Mike A. Harris 2001-09-22 04:47:15 EDT
Deferring for future consideration.
Comment 2 Mike A. Harris 2002-11-03 02:13:45 EST
It is just as easy for a user to install a replacement mga_drv.o along
with hallib as it is to just install hallib.  Matrox's hallib really
should be used with their latest driver source anyway.  Red Hat doesn't
support systems using hallib, and since there's no major benefit to
having the default driver allow hallib - when it is just as easy to
install both files simultaneously, I don't see the benefit here to
enabling hallib support on our side - neither to Red Hat, nor to our
users.

Matrox can package up an RPM or tarball of the necessary bits quite
easily.  Their mga driver can even co-reside with the one that we
ship, simply by using ModulePath directives in the config file.  I
believe this gives a lot more flexibility, as it allows one to use
both drivers, and switch between them.  If a user has a problem with
the Matrox driver and hallib, they can disable it, and use our driver
to try and reproduce the problem.

Closing WONTFIX

Note You need to log in before you can comment on or make changes to this bug.