Bug 538617 - Sound theme is missing desktop-login
Summary: Sound theme is missing desktop-login
Alias: None
Product: Fedora
Classification: Fedora
Component: sound-theme-freedesktop
Version: 13
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2009-11-18 22:58 UTC by Richard Schwarting
Modified: 2015-01-14 23:24 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2011-04-26 16:57:43 UTC
Type: ---

Attachments (Terms of Use)

Description Richard Schwarting 2009-11-18 22:58:10 UTC
Description of problem:

I used to hear a nice little login noise when I logged in in Fedora 11.  Now in Fedora 12, I don't.  Investigating, I find that the "GNOME Login Sound" Start Program entry still exists, and it still tries to run:
/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

But when run, it now encounters this error:
Failed to play sound: File or data not found

Investigating, I see that the following file no longer exists, while it does on another F11 machine:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. login to desktop
2. wait to hear that beautiful welcome noise, that cup of joe in my auditory morning
Actual results:
silence, like death in a cemetery

Expected results:
A heart-warming strum of the guitar, or something else nice.

Additional info:

Comment 1 Lennart Poettering 2009-11-20 00:23:02 UTC
I am not happy with Jon's selection of sounds either. But since he now took it over its up to him to deal with this bug.

Comment 2 Eddie Lania 2009-11-28 11:23:55 UTC
I am having the same issue.

Comment 3 udo 2009-12-22 16:37:21 UTC
Same here (F12 x86_64).

BTW: where are alternative/additional sound themes?

Given the impact of this bug and the ease of fixing etc, priotrity etc should go up.

Comment 4 pankaj pandey 2010-04-22 14:49:24 UTC
Its been quite long. This must be easy to fix. Please fix it atleast before F13 ships. It seems very unpolished. (I don't have login sound in F13 beta as well)

Comment 5 FSW 2010-05-28 08:34:07 UTC
Bug still here in official Fedora 13 x86_64!!!

But it's not Fedora only, as Debian has this trouble also:


The problem is simple to solve anyway, as in "autostarted application", the link points to "/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login", but this file is missing in "/usr/share/sounds/freedesktop/stereo/" and is not even in the .rpm:


So, one needs to replace it, for exemple with "/usr/bin/canberra-gtk-play --id="service-login" --description="GNOME Login" or to put another file (in the same audio format) and save it as "desktop-login.oga"!

Anyway, as the first report here is from 2009-11-18, it is more of a half year to solve a so trivial bug, that's really sad...

Any suggestion about what to do to get that bug solved one for all?

Comment 6 Muayyad Alsadi 2010-06-17 21:48:45 UTC
in F13 there is nothing in "autostarted application" that call canberra-gtk-play

I guess "autostarted application" comes from a .desktop file in /etc/xdg/autostart/

so from which package that .desktop file used to come from

and why it's removed

Comment 7 Mohd Izhar Firdaus Ismail 2010-07-19 12:09:32 UTC
$ rpm -qf /usr/share/gnome/autostart/libcanberra-login-sound.desktop 

$ cat /usr/share/gnome/autostart/libcanberra-login-sound.desktop 
[Desktop Entry]
Name=GNOME Login Sound
Comment=Plays a sound whenever you log in
Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
AutostartCondition=GNOME /desktop/gnome/sound/event_sounds

$ /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
Failed to play sound: File or data not found

Comment 8 David Dreggors 2010-09-10 14:36:38 UTC
I can also confirm this missing sound, as well as the "System" menu's "Startup Application" having the "Gnome Login Sound".

The command is for this Startup Application is: 
/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

Yet I hear no sound on login. If I run this command at command prompt I get the same "File or data not found" error.

I have a work around that works on all my F13 (i386 & x64) installs.

1. sudo yum -y install moblin-sound-theme
2. sudo cp /usr/share/sounds/moblin/stereo/desktop-login.ogg /usr/share/sounds/

The missing 'desktop-login.ogg' is only in the moblin-sound-theme package so we have to install it first. Then, because 'canberra-gtk-play' wants to find this file in '/usr/share/sounds' we have to copy it there. I have tried placing this file under '/usr/share/sounds/freedesktop/stereo' but 'canberra-gtk-play' will not seem to find it there.

All works fine now and I hear login sound now.

Comment 9 udo 2010-09-10 14:48:29 UTC
Great workaround in comment #8.
Can we now package all this together before Fedora 14, please?

Comment 10 Kelvin J. Hill 2010-11-05 17:27:23 UTC
To activate new sounds, you have to remove the cached information first.
Look in ~/.cache and you may see something like "event-sound-cache.tdb.c65f2691af37ece61908d4f100000031.i386-redhat-linux-gnu"

Remove it and rerun the /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login" command again to reload the cache.

Then you can have all the new (old!!) sounds in /usr/share/sounds/freedesktop/stereo available again.


Comment 11 Ionut Biru 2010-12-01 01:13:56 UTC

no idea what is the plan here but "soon" is not meant to be more than 1 year

Comment 12 Robert Hinson 2011-02-07 15:39:17 UTC
Yeah, this is a better link.


It was in sound-theme-freedesktop-0.6.

But on the page in the link it says they took the sound out.

2009-09-28	remove desktop login/logout for now

Comment 13 David Dreggors 2011-04-21 18:19:45 UTC
What is happening with this?

This has been confirmed by many and the problem identified (by community) and a fix suggested. Here we are a year and a half later in F14 with the same issue still here.

No offense, but seriously how can it take 1 year and 5 months to get a single ogg sound file in an rpm?

Are there other issues we are not aware of?

Comment 14 jmccann 2011-04-26 16:57:43 UTC
It isn't missing.  It was removed on purpose.  You are welcome to add it on your own system of course but overall we are much better off without it.

Comment 15 David Dreggors 2011-04-26 17:39:27 UTC
I can respect that the Fedora team feels "better off without it", but what about the community? Obviously there is a want for a login sound or this bug, all the people that have posted to it, and the number of returns on other forums for this issue shows that.

If you will not put the login sound back in, then can we at least have a new rpm named something like "desktop-sounds-extras" or something that will add it back in?

I see two issues here:

1. Leaving it out leaves Fedora in a state of error. The "Gnome Login Sound" under "System->Preferences->Startup Applications" should not point to a sound file that Fedora refuses to package. 

2. You say "You are welcome to add it on your own system" and this is true, but only for those that know that the only way to add it is to install a package that is not meant for Gnome desktop (moblin-sound-theme). Then that is not even sufficient... you have to run other commands after install of the rpm:

sudo cp /usr/share/sounds/moblin/stereo/desktop-login.ogg /usr/share/sounds/

How is leaving the system in a state of err (point 1) considered a solution? 
How can you say that the solution is to add it back in when only a few people here in this bug would know how to add it?

Further more, who decided we are better off without it?
When did the community ask for this to be removed?
Isn't Fedora a community driven distro?

Comment 16 Valerii 2011-05-16 08:23:00 UTC
Installed package sound-theme-freedesktop-0.7-3.el6.noarch missing file :


To which set the path at startup :

/usr/bin/canberra-gtk-play - id = "desktop-login" - description = "GNOME Login"

Who did it and why... remains a mystery. Solve the problem in the following way:

# rpm-Uvh - force http://mirror.yandex.ru/fedora/russianfedora/releases/11/RFRemix/i386/os/Packages/sound-theme-freedesktop-0.2-3.fc11.noarch.rpm

And this excludes the package from automatic updates:


cachedir = / var / cache / yum / $ basearch / $ releasever
keepcache = 0
debuglevel = 2
logfile = / var / log / yum.log
exactarch = 1
obsoletes = 1
gpgcheck = 1
plugins = 1
installonly_limit = 3
exclude = redhat-logos, sound-theme-freedesktop

Note You need to log in before you can comment on or make changes to this bug.