Bug 538661 - SELinux is preventing /usr/bin/python "search" access on 16049.
Summary: SELinux is preventing /usr/bin/python "search" access on 16049.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:a560ad1201d...
: 538662 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 01:34 UTC by Jacob Isreal
Modified: 2009-12-02 04:37 UTC (History)
6 users (show)

Fixed In Version: 3.6.32-49.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 16:40:30 UTC


Attachments (Terms of Use)

Description Jacob Isreal 2009-11-19 01:34:27 UTC
Summary:

SELinux is preventing /usr/bin/python "search" access on 16049.

Detailed Description:

[yum has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by yum. It is not expected that this access is
required by yum and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                16049 [ dir ]
Source                        yum
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.5-127.fc12.x86_64 #1 SMP Sat Nov 7 21:11:14
                              EST 2009 x86_64 x86_64
Alert Count                   4
First Seen                    Wed 18 Nov 2009 07:22:36 PM CST
Last Seen                     Wed 18 Nov 2009 07:25:30 PM CST
Local ID                      1c40e3c3-7a86-408c-962b-6d29882e7243
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1258593930.774:20976): avc:  denied  { search } for  pid=21194 comm="yum" name="16049" dev=proc ino=2061851 scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=dir

node=(removed) type=AVC msg=audit(1258593930.774:20976): avc:  denied  { getattr } for  pid=21194 comm="yum" path="/proc/16049/status" dev=proc ino=2229294 scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=file

node=(removed) type=SYSCALL msg=audit(1258593930.774:20976): arch=c000003e syscall=4 success=yes exit=0 a0=2446d50 a1=7fff837f7810 a2=7fff837f7810 a3=20 items=0 ppid=21193 pid=21194 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="yum" exe="/usr/bin/python" subj=system_u:system_r:abrt_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-41.fc12,catchall,yum,abrt_t,unconfined_t,dir,search
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t unconfined_t:dir search;
allow abrt_t unconfined_t:file getattr;

Comment 1 Daniel Walsh 2009-11-19 14:38:01 UTC
Fixed in selinux-policy-3.6.32-46.fc12.noarch
Availabel in updates-testing

Comment 2 Daniel Walsh 2009-11-19 14:38:29 UTC
*** Bug 538662 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2009-11-23 23:36:40 UTC
selinux-policy-3.6.32-49.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-49.fc12

Comment 4 Fedora Update System 2009-11-25 15:19:38 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12131

Comment 5 Fedora Update System 2009-12-02 04:31:16 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.