Bug 538678 - [abrt] crash detected in gnome-panel-2.28.0-13.fc12 (/usr/libexec/wnck-applet): wncklet_connect_while_alive
[abrt] crash detected in gnome-panel-2.28.0-13.fc12 (/usr/libexec/wnck-applet...
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Patch, Triaged
: 534177 538269 538791 539307 539381 542030 542561 542766 542813 547861 550756 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2009-11-18 23:07 EST by David
Modified: 2010-12-03 22:10 EST (History)
29 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-12-03 22:10:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (5.41 KB, text/plain)
2009-11-18 23:07 EST, David
no flags Details
Backtrace (29.82 KB, text/plain)
2010-02-26 05:09 EST, Jay Mist
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 472773 None None None Never

  None (edit)
Description David 2009-11-18 23:07:27 EST
abrt detected a crash.

Comment: I turned desktop effects on, and then tried to open the settings menu of the workspace switcher applet
Attached file: backtrace
cmdline: /usr/libexec/wnck-applet --oaf-activate-iid=OAFIID:GNOME_Wncklet_Factory --oaf-ior-fd=18
component: gnome-panel
executable: /usr/libexec/wnck-applet
package: gnome-panel-2.28.0-13.fc12
rating: 3
reason: Process was terminated by signal 11
Comment 1 David 2009-11-18 23:07:29 EST
Created attachment 370261 [details]
File: backtrace
Comment 2 Robert Elliott 2009-11-22 13:15:43 EST
Similar situation with me, except I don't have - and have never had - the desktop effects running. The applet crashed every time I tried to get into the workspace switcher properties.
Comment 3 Ray Strode [halfline] 2009-12-01 13:20:16 EST
*** Bug 534177 has been marked as a duplicate of this bug. ***
Comment 4 Ray Strode [halfline] 2009-12-01 13:21:07 EST
*** Bug 538791 has been marked as a duplicate of this bug. ***
Comment 5 Ray Strode [halfline] 2009-12-01 13:21:24 EST
*** Bug 539307 has been marked as a duplicate of this bug. ***
Comment 6 Ray Strode [halfline] 2009-12-01 13:25:18 EST
*** Bug 539381 has been marked as a duplicate of this bug. ***
Comment 7 Ray Strode [halfline] 2009-12-01 13:43:23 EST
*** Bug 538269 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2009-12-01 13:43:30 EST
*** Bug 542030 has been marked as a duplicate of this bug. ***
Comment 9 Ray Strode [halfline] 2009-12-01 13:43:39 EST
*** Bug 542561 has been marked as a duplicate of this bug. ***
Comment 10 Ray Strode [halfline] 2009-12-01 13:43:47 EST
*** Bug 542766 has been marked as a duplicate of this bug. ***
Comment 11 Ray Strode [halfline] 2009-12-01 13:43:54 EST
*** Bug 542813 has been marked as a duplicate of this bug. ***
Comment 12 Karel Klíč 2010-02-24 12:05:16 EST
*** Bug 547861 has been marked as a duplicate of this bug. ***
Comment 13 Karel Klíč 2010-02-24 12:05:21 EST
*** Bug 550756 has been marked as a duplicate of this bug. ***
Comment 14 Matteo Corti 2010-02-24 12:13:58 EST
I can reproduce the problem every time I log in:
- the desktop switcher appears with as if the 'Show workspace names in switcher' was off (but it is in fact checked)
- right-mouse click to open the preferences
- crash
- I get the dialog asking me if I want to reload it
- I click reload
- it appears correctly (with the desktop names)
- right clicking and opening the preferences works
Comment 15 Jay Mist 2010-02-25 03:02:24 EST
1. Tried to configure Workspace Switcher applet in panel.
2. Right-clicked to change configure options since was not able to toggle windows with mouse scroll wheel.
3. Applet (Workspace Switcher) crash.
(am attaching backtrace generated by ABRT)
Comment 16 Jay Mist 2010-02-26 05:09:56 EST
Created attachment 396505 [details]

Backtrace generated by ABRT.
Comment 17 Jeff Raber 2010-07-27 23:39:35 EDT

Fedora Bugzappers volunteer triage team
Comment 18 Jeff Raber 2010-07-27 23:49:56 EDT
This bug is the same as 552423 which was resolved in gnome-panel-2.30.0-4.fc13.  Unfortunately the fix has not been applied to F12 (yet?).  The patch is available on the upstream bug.

Halfline,  Please apply this patch to F12 gnome-panel, or close this bug as NEXTRELEASE.
Comment 19 Bug Zapper 2010-11-04 02:06:45 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 20 Bug Zapper 2010-12-03 22:10:48 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.