Bug 53877 - gpm trouble when no mouse is configured
gpm trouble when no mouse is configured
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-20 11:31 EDT by David Balažic
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 17:58:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2001-09-20 11:31:07 EDT
Description of Problem:

After kudzu uninstalled my PS/2 mouse I noticed several gpm related 
problems :

( - the /etc/init.d/gpm file states in the comments that is uses the
   /etc/sysconfig/mouse as a configuration file. It forgets to mention
   /etc/sysconfig/gpm , which is also used )

 - I discovered this after kudzu removed the mouse from the system :
   - the gpm executable is executed by the /etc/init.d/gpm script,
     even if no mouse is configured
   - the /etc/init.d/gpm script is executed at startup , even if no mouse 
is configured 
   - after gpm is started , it fails with the following message :
Starting console mouse services            [OK]
gpm: oops() invoked from gpm.c(978)
/dev/mouse: No such file or directory 



Version-Release number of selected component (if applicable):

standard redhat linux 7.2 installation.

How Reproducible:

Set up a system with one PS/2 mouse ( I gues other mouse types are good 
oo ). Deinstall the mouse. I set the "safe=yes" option 
in /etc/sysconfig/kudzu. After that on next boot kudzu will claim that the 
mouse was removed and it will offer to de-install the mouse configuration. 
I guess simply unplugging the mouse works too ( before the reboot )
Comment 1 Josep L. Guallar-Esteve 2002-03-22 11:32:39 EST
* test tree Skipjack-re0320.0 (beta3) i586 
* test hardware: ps/2 mouse, ps/2 keyboard, Compaq Proliant 
ML330 
* booting at Runlevel 5 by default (gdm) 
 
I disconnected the ps/2 mouse on test machine. I rebooted. 
Kudzu came up and asked if I wanted to remove the mouse 
configuration. I removed it. No gpm nor X came up (the proper 
way to act).   
 
I changed the configuration file /etc/sysconfig/kudzu to 
SAFE=yes. I rebooted. X tried to start but it was unable to 
suceed: the X-reconfig tool show up, but it was unable to 
self-reconfigure (this is, obviously, OK: no mouse, no X) and, 
in the end, X and GDM had to be disabled, As I said, this is 
OK, expected behaviour. After pluging in the mouse back and 
rebooting, X comes alive right and well. 
 
But I get no Ooops nor other problem.
Comment 2 David Balažic 2002-03-27 06:06:21 EST
This was on a beta2 system ( 7.2.91 )

Installed beta2, with aPS/2 mouse.
Then I disconnected the PS/2 mouse, rebooted.

kudzu noticed the mouse was missing, asked about it,
I selecte "Remove Configuration", then the system normaly booted.

But :
[root@localhost root]# service gpm status
gpm dead but pid file exists
[root@localhost root]# service gpm stop
Shutting down console mouse services:                      [FAILED]
[root@localhost root]# service gpm status
gpm dead but subsys locked
[root@localhost root]#

Part of the problem is that /etc/init.d/gpm uses the following logic to
determine if a mouse is present :

MOUSECFG=/etc/sysconfig/mouse

        if [ -f "$MOUSECFG" ]; then
                . "$MOUSECFG"
        else
                echo $"(no mouse is configured)"
                exit 0
        fi

        if [ "$MOUSETYPE" = "none" ]; then
                echo $"(no mouse is configured)"
                exit 0
        fi

But when unconfiguring the mouse, kudzu does not remove the
/etc/sysconfig/mouse file, neither does it modify it to say MOUSETYPE=none.
So the script tries to start the gpm subsystem.

Another problem is that a lockfile and a pidfile for the gpm service are 
created , even if gpm fails to start ( which is due to /dev/mouse file missing, 
kudzu got at least this right ).

Also tested on beta3 7.2.92, versions :
kudzu-0.99.47-1
gpm-1.20.0-1

exactly the same behavior as with beta2

Comment 3 David Balažic 2002-04-10 11:23:06 EDT
Same on beta4 ( 7.2.93 )
gpm-1.20.0-2
kudzu-0.99.48-1
Comment 4 David Balažic 2002-12-11 05:29:27 EST
Same in RHL 8.0 ( Psyche )

Versions :
gpm-1.19.3-23
kudzu-0.99.69-1
Comment 5 David Balažic 2003-02-26 04:46:20 EST
Same in 8.0.93 ( Phoebe2 )

Versions :
gpm-1.19.3-25
kudzu-0.99.97-1 

Changing component to kudzu.

Description of the problem , again :

When the mouse is removed , kudzu does not delete /etc/sysconfig/mouse or 
alternatively, it does not change it to say MOUSETYPE="none"

Can we mark this bug as public ?
Comment 6 Bill Nottingham 2005-02-04 17:58:26 EST
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please attempt to confirm with more recent releases.

Note You need to log in before you can comment on or make changes to this bug.