Bug 538795 - Docky theme is missing regression
Summary: Docky theme is missing regression
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-do
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Sindre Pedersen Bjørdal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 12:50 UTC by alexf
Modified: 2009-12-07 07:29 UTC (History)
4 users (show)

Fixed In Version: 0.8.2-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-07 07:29:44 UTC
Type: ---


Attachments (Terms of Use)

Description alexf 2009-11-19 12:50:18 UTC
Description of problem:
The F12 version of gnome-do doesn't seem to include the docky theme. This is a regression, since the F11 version did. Docky isn't just a theme, it conveniently allows to operate gnome-do via mouse while looking very good. The themes that are available now can only be used via keyboard.

Version-Release number of selected component (if applicable):
gnome-do-0.8.2-4.fc12.x86_64

How reproducible:
Install gnome-do and try changing theme to docky. The docky theme is missing from the dropdown selection menu.
  
Actual results:
No docky theme.

Expected results:
The docky theme!

Comment 1 Juan Manuel Rodriguez 2009-11-19 14:54:02 UTC
It was removed due to a possible violation of some US Patent, but it's coming back in 0.8.2-5, though without "Icon Magnification". 

http://admin.fedoraproject.org/updates/gnome-do-0.8.2-5.fc12?_csrf_token=6f5f028d102028746069fe2d75b7294c1fba1b51

Comment 2 Fedora Update System 2009-11-20 05:27:33 UTC
gnome-do-0.8.2-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-do'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11802

Comment 3 Thomas Ahle 2009-11-24 01:42:53 UTC
Does the US patent apply anywhere, or would it be possible to disable the magnification only for US citizens?

Comment 4 Juan Manuel Rodriguez 2009-11-24 01:50:21 UTC
It only applies for US Software, and Fedora happens to be based in the US. There are other repositories which could host a non-crippled gnome-do, or you could recompile it yourself. 

Either way, the 'Docky' theme will be removed completely from gnome-do in a future release (Based on Upstream), and a separate package, named Docky, will take over it.

Comment 5 Fedora Update System 2009-12-07 07:29:35 UTC
gnome-do-0.8.2-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.