Bug 538836 - KDE Launcher causes desktop to freeze for ~10 seconds (radeon dual-head)
Summary: KDE Launcher causes desktop to freeze for ~10 seconds (radeon dual-head)
Keywords:
Status: CLOSED DUPLICATE of bug 533620
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 14:35 UTC by Mary Ellen Foster
Modified: 2009-11-27 18:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 533620
Environment:
Last Closed: 2009-11-27 18:12:19 UTC


Attachments (Terms of Use)
lspci -vvnn output showing details of an affected radeon X550 card (21.80 KB, text/plain)
2009-11-21 23:40 UTC, Travers Carter
no flags Details
/var/log/messages from booting _with_ the patch (problem present) (54.87 KB, text/plain)
2009-11-21 23:41 UTC, Travers Carter
no flags Details
Xorg log _with_ the patch (problem present) (55.24 KB, text/plain)
2009-11-21 23:42 UTC, Travers Carter
no flags Details
/var/log/messages from booting _wihout_ the patch (problem not present) (54.74 KB, text/plain)
2009-11-21 23:43 UTC, Travers Carter
no flags Details
Xorg log _without_ the patch (problem not present) (55.25 KB, text/plain)
2009-11-21 23:43 UTC, Travers Carter
no flags Details

Description Mary Ellen Foster 2009-11-19 14:35:57 UTC
+++ This bug was initially created as a clone of Bug #533620 +++

Description of problem: When clicking the KDE launcher the entire screen freezes for about 10 seconds.

These are the identical symptoms to those in Bug 533620, but on different hardware: Acer TravelMate 8100 laptop with an ATI X700 radeon mobility graphics card (using the free "radeon" driver). The slowness only appears when a second monitor is plugged in, and the Xorg package that works around the nVidia issue also alleviate the symptoms on this laptop.


Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.x86_64

Comment 1 Adam Williamson 2009-11-19 20:28:37 UTC
seems to be a hardware-specific bad interaction with the infamous X.org window-pictures.patch . Mary, did you confirm that the scratch build provided by me or Rex, from 533620, works OK for you?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Mary Ellen Foster 2009-11-19 21:42:46 UTC
Yes, using that package fixed the issue on the Acer laptop too.

Comment 3 Adam Williamson 2009-11-19 21:54:35 UTC
right - so, dave and jerome, that definitely indicates the window-pictures patch exposes a problem in radeon here (the scratch build is identical to 1.7.1-7 but without window-pictures patch).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Adam Williamson 2009-11-19 21:55:06 UTC
oh, can we get /var/log/Xorg.0.log and /var/log/messages both from a session where you boot with the *bad* configuration and one where you boot with the *good* configuration? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Mary Ellen Foster 2009-11-20 10:05:28 UTC
(In reply to comment #4)
> oh, can we get /var/log/Xorg.0.log and /var/log/messages both from a session
> where you boot with the *bad* configuration and one where you boot with the
> *good* configuration? Thanks.

Just to be clear: you mean we should rollback to the stock Xorg stuff, boot and save the logs, then upgrade back to the rebuilt Xorg (minus patch) and save those logs too? Just wanted to be sure because it's my husband's work laptop this is happening on, so I don't want him to have to do any unnecessary package manipulation ...

Comment 6 Adam Williamson 2009-11-20 21:17:05 UTC
yes, please - I recognize it's a bit of a pain but it's really necessary to hopefully identify what the problem is. thanks.

(btw, dave/jerome, I'm assuming you're aware of the upstream bug the NVIDIA guys filed, in case that plays into it. yell if you're not.)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Travers Carter 2009-11-21 23:40:10 UTC
Created attachment 372825 [details]
lspci -vvnn output showing details of an affected radeon X550 card

I am experiencing the same problem on a PCIe X550 card (also in a dual-head configuration), removing the window-pictures patch resolves the symptoms for me too.

I've attached the same logs as were requested of the original reporter.

lspci -vvnn output is also attached.

Comment 8 Travers Carter 2009-11-21 23:41:18 UTC
Created attachment 372826 [details]
/var/log/messages from booting _with_ the patch (problem present)

Comment 9 Travers Carter 2009-11-21 23:42:16 UTC
Created attachment 372828 [details]
Xorg log _with_ the patch (problem present)

Comment 10 Travers Carter 2009-11-21 23:43:02 UTC
Created attachment 372829 [details]
/var/log/messages from booting _wihout_ the patch (problem not present)

Comment 11 Travers Carter 2009-11-21 23:43:46 UTC
Created attachment 372830 [details]
Xorg log _without_ the patch (problem not present)

Comment 12 Adam Williamson 2009-11-23 19:53:34 UTC
Can you please test this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1821848

and see if that resolves the issue? Thanks.

To recap, for clarity (posting this to all three bugs): we have three bugs for this issue at present, as they manifested with different drivers and hardware.

Bug #533620 is the initial bug, considered to refer to using the NVIDIA proprietary driver. Bug #538836 is for a case affecting users of the 'radeon' driver for ATI/AMD cards in a dual-head configuration. And Bug #539768 is for a case affecting the free 'nouveau' driver for NVIDIA hardware with kernel modesetting disabled.

If the proposed scratch build appears to fix all three types, I'll re-combine them into bug 533620, as it would then be considered a bug in the X server addressed by the proposed patch in the scratch build (from NVIDIA).

Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Travers Carter 2009-11-23 23:51:43 UTC
Yes, the scratch build from comment 12 resolves the issue for me (radeon X550).

Comment 14 Adam Williamson 2009-11-24 15:42:48 UTC
Thanks - Mary, could you check too?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 15 Travers Carter 2009-11-25 03:01:30 UTC
After testing the build from comment 12 further it appears that it introduces graphical corruption of the mouse pointer in some circumstances, the mouse pointer turns into a random looking (32x32?) square on one monitor.  This problem only seems to occur on one monitor at a time, ie when the problem is present sometimes the pointer is fine on the left monitor but corrupt on the right, other times the situation is reversed, I've never seen the pointer corrupted on both monitors at any one time.

I've rolled back to the build excluding the window-pictures patch to try to confirm that the problem is actually introduced by the new build.

Comment 16 Travers Carter 2009-11-25 22:22:40 UTC
The mouse pointer corruption eventually showed up with the old build, so I don't think it's related to this bug.

Comment 17 Adam Williamson 2009-11-27 18:12:19 UTC
it seems pretty clear that all the different cases of this actually stem from one bug in the X server, so closing as a dupe of the original bug again. apologies for making you file the clone :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 533620 ***


Note You need to log in before you can comment on or make changes to this bug.