Bug 53884 - cp returns error code if non-recursive copy encounters dir
cp returns error code if non-recursive copy encounters dir
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-20 15:02 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 17:50:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-20 15:02:00 EDT
Description of Problem:
cp returns an error code when encountering a directory in a non-recursive
copy;

Version-Release number of selected component (if applicable):


How Reproducible:
mkdir a
mkdir a/b
mkdir a/b/c
mkdir d
touch a/b/foo
cd a
if cp b/* ../d ; then echo Good ; else echo bad ; fi

Actual Results:
makefile, util, etc, exit as if command fails. cp has no command to ignore
the directory, thus all script are cripled;

Expected Results:
either cp to return success (you said non-recursive copy, I did. Job well
done!)
or at least a --ignore-directories
Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-08-29 18:48:34 EDT
This is the intended behavior according to POSIX.

Note You need to log in before you can comment on or make changes to this bug.