Bug 538853 - hardware device hardcoded
hardware device hardcoded
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: recordmydesktop (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
http://drowninginbugs.blogspot.com/20...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 10:11 EST by Christoph Wickert
Modified: 2010-03-05 22:47 EST (History)
3 users (show)

See Also:
Fixed In Version: recordmydesktop-0.3.8.1-4.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-15 17:08:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2009-11-19 10:11:43 EST
Description of problem:
recordmydesktop uses always uses "hw:0,0" instead of the "default" soundcard.

Version-Release number of selected component (if applicable):
recordmydesktop-0.3.8.1-2.fc12

Additional info:

--- recordmydesktop-0.3.8.1.orig/src/rmd_types.h
+++ recordmydesktop-0.3.8.1/src/rmd_types.h
@@ -39,7 +39,7 @@
#ifdef HAVE_LIBASOUND
#include

- #define DEFAULT_AUDIO_DEVICE "hw:0,0"
+ #define DEFAULT_AUDIO_DEVICE "default"
#else
#include
#include
Comment 1 Fedora Update System 2010-01-15 05:22:13 EST
recordmydesktop-0.3.8.1-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/recordmydesktop-0.3.8.1-4.fc12
Comment 2 Fedora Update System 2010-01-15 05:22:37 EST
recordmydesktop-0.3.8.1-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/recordmydesktop-0.3.8.1-4.fc11
Comment 3 Till Maas 2010-01-15 05:26:58 EST
(In reply to comment #0)

> --- recordmydesktop-0.3.8.1.orig/src/rmd_types.h
> +++ recordmydesktop-0.3.8.1/src/rmd_types.h
> @@ -39,7 +39,7 @@
> #ifdef HAVE_LIBASOUND
> #include
> 
> - #define DEFAULT_AUDIO_DEVICE "hw:0,0"
> + #define DEFAULT_AUDIO_DEVICE "default"
> #else
> #include
> #include    

This patch was broken, I guess because some filter removed the info after #include, to remove html-tags. Please attach the patch next time, to avoid unwanted modifications.
Comment 4 Fedora Update System 2010-01-15 17:08:19 EST
recordmydesktop-0.3.8.1-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-01-15 17:16:37 EST
recordmydesktop-0.3.8.1-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2010-03-01 20:06:56 EST
recordmydesktop-0.3.8.1-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-03-02 21:01:40 EST
recordmydesktop-0.3.8.1-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-03-03 19:21:11 EST
recordmydesktop-0.3.8.1-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-03-05 22:47:15 EST
recordmydesktop-0.3.8.1-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.