Bug 538856 - Segmentation fault inside gvnc_fill_fast_32x32
Segmentation fault inside gvnc_fill_fast_32x32
Status: CLOSED DUPLICATE of bug 540810
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
abrt_hash:2e90fb0f650d796cdb2506ef9d1...
:
: 545391 546372 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 10:22 EST by gcarter
Modified: 2010-04-26 14:27 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 14:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.94 KB, text/plain)
2009-11-19 10:22 EST, gcarter
no flags Details

  None (edit)
Description gcarter 2009-11-19 10:22:16 EST
abrt detected a crash.

Comment: Virtual Machine Management Console just blew up.
Attached file: backtrace
cmdline: python /usr/share/virt-manager/virt-manager.py
component: python
executable: /usr/bin/python
kernel: 2.6.31.5-127.fc12.x86_64
package: python-2.6.2-2.fc12
rating: 2
reason: Process was terminated by signal 11
Comment 1 gcarter 2009-11-19 10:22:18 EST
Created attachment 370366 [details]
File: backtrace
Comment 2 Dave Malcolm 2009-11-19 11:52:06 EST
Thanks for filing this bug report.

Are you able to reproduce this issue?

Looking at the backtrace, it appears to be a problem deep inside the "gvnc" code, so I'm reassigning the component from "python" to "gtk-vnc" and updating the summary.
Comment 3 Daniel Berrange 2009-11-19 12:06:59 EST
Unfortunately the stack trace is pretty much useless due to the compiler optimizing away all the variables.

If you can reproduce it, then it'd be very useful to get a trace from


  virt-viewer --gtk-vnc-debug  $GUESTNAME

Otherwise there's not much I can do to diagnose beyond simply peering at the code & I can't see any obvious problems there yet
Comment 4 Daniel Berrange 2009-12-13 12:23:32 EST
*** Bug 545391 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Berrange 2009-12-13 12:23:41 EST
*** Bug 546372 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Berrange 2010-04-26 14:27:23 EDT

*** This bug has been marked as a duplicate of bug 540810 ***

Note You need to log in before you can comment on or make changes to this bug.