Bug 538911 - Fedora 12 i386 installation hangs on Dell XPS 630
Summary: Fedora 12 i386 installation hangs on Dell XPS 630
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 16:00 UTC by Roger Noble
Modified: 2010-12-04 03:09 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-04 03:09:20 UTC
Type: ---


Attachments (Terms of Use)
lspci -v output (8.83 KB, application/octet-stream)
2009-11-19 16:00 UTC, Roger Noble
no flags Details

Description Roger Noble 2009-11-19 16:00:29 UTC
Created attachment 370603 [details]
lspci -v output

Description of problem:

An attempt to install Fedora 12 using the i386 DVD fails when the installation hangs after the Probing EDD step.

initrd.img loads OK and says ready. The EDD probe apparently succeeds in that it says ok, but then the installation hangs with no response to the keyboard and no further output. It still hangs with edd=off. Similarly with noprobe and all other options I have tried.

The i686 Live CD (KDE) boots and runs OK.

I have attached the output of lspci -v for the machine if this is of any use. The machine has a DVD drive and a Blu-ray writer. The problem happens with the DVD in either drive.

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. Load i386 Ferdora 12 DVD
2. Boot machine
3. Select install or upgrade
  
Actual results:
Installation hangs.

Expected results:


Additional info:

Comment 1 Heiko Burghardt 2009-11-26 10:28:19 UTC
I see exactly the same on a Dell OptiPlex 740, latest BIOS version. Tried a bit with Kernel boot options like 'noprobe', etc. but it does not help.

Comment 2 Ibrahim 2009-12-11 01:11:53 UTC
exact same thing happened to me.
tried the install dvd and the live cd. install hangs right after i choose to install.

Comment 3 Mark A. McFarland 2010-01-06 16:41:30 UTC
Is there any resolution on this bug?
It has rendered my machine useless.

This is quite serious. 
Any guidance would be appreciated.

Comment 4 Sanchez 2010-01-12 20:17:31 UTC
Exact same happened to me. I have Dell Optiplex 740, 6 GB RAM...
I have found workaround to install Fedora 12 x86_64 to may PC.
I use Kernel boot option mem=xxx. In my case "mem=6442450944" (6GB=6*1024*1024*1024). 

After successful installation and reboot PC, Fedora hang :-( (another bug ?). 

I have boot fresh install of Fedora to rescue mode and perform update packages & kernel via ÿum update. Then Fedora boot & working without problems....

my exact steps:

1 - boot PC from install DVD
2 - add kernel option mem=.... and start installation of Fedora 12
3 - after installation ended, boot Fedora to rescue mode (for example from install DVD), whith the same option mem=....
4 - setup your network.
5 - chroot /mnt/sysimage 
6 - when needed setup yum.conf (for example add yor proxy,...)
7 - perform yum update
8 - reboot

I hope this help.

enjoy :-))

Comment 5 Ibrahim 2010-01-12 23:48:35 UTC
used above steps
after ad added kernel option mem=6442450944 (im also 6GB ram), installation ran fine.

os was also able to boot fine without any extra steps after above mentioned step 2.

Comment 6 Roger Noble 2010-01-13 12:08:38 UTC
I can confirm that this workaround also fixes the original problem with an i386 installation Dell XPS 630 with 8 GB ram: the installation successfully gets through to running anaconda.

I didn't continue any further because I had already installed Fedora 12 via the i686 Live CD.

Comment 7 Mukesh Chauhan 2010-02-13 13:02:47 UTC
Hi, I am using Dell Vostro 1015 (2G RAM). When I try installing Fedora 12, it hangs. Everytime it hangs at different places. 

I also tried using mem option but did not work for me. Any other work around for it.

Comment 8 Adam 2010-03-22 22:40:34 UTC
Same issue with me as Mikesh. It hangs at random points during the install on Lenovo T400. I've tried several times and it even one time got as far as installing package 443/1178 and then just hung again.

Comment 9 Gary Gatling 2010-05-05 18:53:22 UTC
I am seeing the same problem with a DELL Optiplex 740 at latest BIOS.

I was able to install with:

mem=4294967296

as argument at install time. (I have 4 GB or RAM) I am also seeing this problem with RHEL 6 beta as well as fedora 12. Problem seems to happen with Fedora 12 either with 32 or 64 bit installer DVD.

Comment 10 Bug Zapper 2010-11-04 06:02:43 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Bug Zapper 2010-12-04 03:09:20 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.