Bug 53896 - mixer settings are reset arbitrarily without notice, nor mention
mixer settings are reset arbitrarily without notice, nor mention
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: aumix (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-20 18:37 EDT by Jeff Lane
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-30 02:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Lane 2001-09-20 18:37:56 EDT
Description of Problem:
Trying to record wav files from an external source, using grecord.  mixer
settings are set by aumix.  occasionally (read every so often) the mixer
settings are reverted back to some default setting without permission, nor
notifications.

For example... I record a file now, and my settings are correct.  I close
aumix, and go about my business...  later I decide to record a new .wav
file and after recording, I learn that the rec level has been reset to 0.

Both root and my users .aumixrc shows the correct rec level (between 95 and
100), however, as stated, on occasion, the settigns are returned to some
previous value.  

Version-Release number of selected component (if applicable):

aumix 2.7-2 on a stock full 7.1 install with all current errata installed.

How Reproducible:

Not sure.  this is another of those bugs that just happen.  There are no
log messages generated, nothing to stdout or stderr. 

Steps to Reproduce:

Normally, it happens this way.

1. set settings in aumix and set record to something high. 
2. record something using grecord
3. close aumix after hitting s for save.
4. wait a while (maybe 30 minutes to an hour) and record something else.
5. opem aumix again and check levels...

Actual Results:

when this happens, I find that the record and several other settings have
been mysteriously reset to some other setting that is apparently cached
somewhere, but I cant find it.  THis occurs no matter which user is doing
the setting or recording, AND happens when I copy a .aumixrc file to both
root and local user directories, so that they are both using the same
aumixrc file to base mixer settings on.


Expected Results:

settings do not change after settign and saving them,

Additional Information:
	Not sure how reproducible, however, Steve Taylor in support is experiencing
the same things on his box at home.  his email is staylor@redhat.com if you
want to contact him.
Comment 1 Mike A. Harris 2002-02-05 12:21:00 EST
What is grecord?  I don't seem to have it.  Where is it from?

It is possible that multiple applications are competing for the mixer
possibly.
Comment 2 Mike A. Harris 2002-05-30 02:15:35 EDT
I don't observe this behaviour with my hardware.  Unable to reproduce.

Probably best to contact the upstream maintainer/developer directly if
problem persists.
Comment 3 Mike A. Harris 2002-05-30 02:15:55 EDT
Whoops, wrong resolution.

Note You need to log in before you can comment on or make changes to this bug.