Bug 53900 - Needs python as dependency
Summary: Needs python as dependency
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Guppi   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-20 23:19 UTC by Enrico Scholz
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 04:29:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-09-20 23:19:16 UTC
Guppi has needs the python-version it was compiled with:

| $ strings /usr/lib/libguppiuseful.so | egrep 'python|1.5.2'
| ...
| lib/python%s
| 1.5.2

When using another python version, Guppi will fail to start:

| Could not find platform independent libraries <prefix>
| Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
| 'import exceptions' failed; use -v for traceback
| Warning!  Falling back to string-based exceptions
| 'import site' failed; use -v for traceback
| Fatal Python error: couldn't import os

Therefore, there should be an explicit 'Requires: python = <version>' where
<version> is the used python-version. Without this it is very difficulty to
determine why programs using guppi are failing (e.g. gnucash).

Comment 1 Bill Nottingham 2002-02-06 03:21:50 UTC
This will be fixed in Guppi-0.40.3-3, because in that version the python support
got removed. ;)


Note You need to log in before you can comment on or make changes to this bug.