Bug 539046 - FTBFS perl-Test-AutoBuild-1.2.2-9.fc12
Summary: FTBFS perl-Test-AutoBuild-1.2.2-9.fc12
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Test-AutoBuild
Version: 13
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Depends On:
Blocks: F13FTBFS 614981
TreeView+ depends on / blocked
 
Reported: 2009-11-19 16:34 UTC by FTBFS
Modified: 2010-07-15 17:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-15 17:26:36 UTC


Attachments (Terms of Use)
root.log (580.29 KB, text/plain)
2009-11-19 16:34 UTC, FTBFS
no flags Details
build.log (44.57 KB, text/plain)
2009-11-19 16:34 UTC, FTBFS
no flags Details
mock.log (1002 bytes, text/plain)
2009-11-19 16:34 UTC, FTBFS
no flags Details
root.log (641.03 KB, text/plain)
2009-11-19 16:34 UTC, FTBFS
no flags Details
build.log (44.96 KB, text/plain)
2009-11-19 16:34 UTC, FTBFS
no flags Details
mock.log (1010 bytes, text/plain)
2009-11-19 16:34 UTC, FTBFS
no flags Details

Description FTBFS 2009-11-19 16:34:37 UTC
perl-Test-AutoBuild-1.2.2-9.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.

Comment 1 FTBFS 2009-11-19 16:34:41 UTC
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow

Comment 2 FTBFS 2009-11-19 16:34:43 UTC
Created attachment 371321 [details]
root.log

root.log for i386

Comment 3 FTBFS 2009-11-19 16:34:45 UTC
Created attachment 371322 [details]
build.log

build.log for i386

Comment 4 FTBFS 2009-11-19 16:34:46 UTC
Created attachment 371323 [details]
mock.log

mock.log for i386

Comment 5 FTBFS 2009-11-19 16:34:47 UTC
Created attachment 371324 [details]
root.log

root.log for x86_64

Comment 6 FTBFS 2009-11-19 16:34:50 UTC
Created attachment 371325 [details]
build.log

build.log for x86_64

Comment 7 FTBFS 2009-11-19 16:34:51 UTC
Created attachment 371326 [details]
mock.log

mock.log for x86_64

Comment 8 Bug Zapper 2010-03-15 13:11:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Ralf Corsepius 2010-06-30 13:16:05 UTC
Daniel, is there any perspective of you making this package working with perl-5.12.x? Otherwise I would propose to retire this package and to remove it from Fedora.

Its upstream (maintainer seemingly being you) appears dead, its upstream build matrix looks frightening, it doesn't seem to be used in Fedora.

ATM, this package is amongst the very few package which doesn't build against perl-5.12.x.

Comment 10 Daniel Berrangé 2010-07-15 17:09:10 UTC
The problem is not with perl 5.12, but rather with the integration with monotone. The monotone tool has changed its command line interface which has broken the integration. The rest of the system works just fine. I will remove the monotone code since it does not appear to be quick or easy to fix.


Note You need to log in before you can comment on or make changes to this bug.