Bug 53911 - Many common words missing from Norwegian dictionary
Summary: Many common words missing from Norwegian dictionary
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aspell-no
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-21 12:58 UTC by Toralf
Modified: 2007-04-18 16:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-10-11 09:12:27 UTC


Attachments (Terms of Use)
Example text (1.65 KB, text/plain)
2001-09-21 12:59 UTC, Toralf
no flags Details
Aspell wordlist; a result of using updated dictionary very briefly (228 bytes, text/plain)
2001-10-04 13:11 UTC, Toralf
no flags Details
Updated version of wordlist (372 bytes, text/plain)
2001-10-11 09:01 UTC, Toralf
no flags Details

Description Toralf 2001-09-21 12:58:32 UTC
Description of Problem:
When spellchecking norwegian texts, errors are reported for many correctly
spelled words, even ones that are very common.

Version-Release number of selected component (if applicable):
aspell-no-0.2-1 or aspell-no-0.2-3

How Reproducible:
Every time

Steps to Reproduce:
1. aspell --language-tag=no -H check aspell-no.txt (see attachment.)


Actual Results:
Several words reported as misspelled, including common ones like "fra"
(meaning "from") and "fulgt" (meaning "followed")

Expected Results:
No errors; this text is taken from the web pages of Norsk Sprekred (The
Norwegian Language Council), so I'm assuming the spelling is correct. 


Additional Information:

Comment 1 Toralf 2001-09-21 12:59:49 UTC
Created attachment 32338 [details]
Example text

Comment 2 Trond Eivind Glomsrxd 2001-09-24 16:48:10 UTC
Sprakradet is the entity okaying "poebb", "roesj" and "soervis", so take
whatever comes from them with a big grain of salt.

That said, I've added the missing words to aspell-no-0.2-4.

Comment 3 Toralf 2001-10-04 13:07:33 UTC
The problem is that plenty of other words are missing, too. The point is really
that some of these are so common that I refuse to believe that they were left
out from the original wordlist. In other words, I believe there is *something*
wrong with the way the package is built, so adding some more words is not a
proper solution to the problem.

Comment 4 Toralf 2001-10-04 13:11:32 UTC
Created attachment 33360 [details]
Aspell wordlist; a result of using updated dictionary very briefly

Comment 5 Toralf 2001-10-11 09:01:24 UTC
Created attachment 33841 [details]
Updated version of wordlist

Comment 6 Toralf 2001-10-11 09:12:23 UTC
I think the following test is quite interesting:

   mv .aspell.norwegian.pws aspell.txt
   aspell --language-tag=no list < aspell.txt

This normally lists the complete contents of the wordlist, of course, but if I do
   rpm -Uvh /mnt/cdrom/RedHat/RPMS/aspell-no-0.1-8.i386.rpm --force
whith Red Hat 7.0 Disc 2 inserted, then repeat, all I get is
% aspell --language-tag=no list < aspell.txt
ws
norwegian
C8lsmak
hipt
sC%fall
navnekonvensjonen
C8yhopping
oj
masing
induksjons

In other words, most of the words missing in the Red Hat 7.1 and current Raw
Hide versions of aspell-no were actually there in the Red Hat 7.0 release.

Comment 7 Trond Eivind Glomsrxd 2002-01-23 20:50:55 UTC
aspell-no-0.3-1 should have this, and more


Note You need to log in before you can comment on or make changes to this bug.