Bug 53926 - Intellimouse Explorer Hardlock
Intellimouse Explorer Hardlock
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-21 14:57 EDT by Josh Olson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 23:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Olson 2001-09-21 14:57:50 EDT
Description of Problem: My 5 button, optical, usb, microsoft intellimouse
explorer hardlocks about every 5-10 minutes in all X platforms. I have
tried kde, gnome, ximian, and blackbox. They all reproduce the same
results. I have talked to many other people who have the same problem. I
have tried with redhat 7.1 and Mandrake 8.0 and a hard lock occurs on both
distros. I am unable to ping the machine once locked, and have to press
restart button.

Version-Release number of selected component (if applicable):
X 4.1.0

How Reproducible:
every 5 - 10 minutes of X

Steps to Reproduce:
1. boot linux - text login
2. startx
3. wait 5-10 minutes

Actual Results: Machine hardlocks, can not ping it, can not
ctrl-alt-backspace, or ctrl-atl-delete, or use keyboard at all. Requires
reset button restart.


Expected Results: X should run stable with mouse.


Additional Information:
Comment 1 Mike A. Harris 2001-09-22 04:44:08 EDT
There are Intellimouse mice that have a hardware bug and you might have
one of them.  I don't recall what the solution is off the top of my head,
so you might want to try xpert@xfree86.org mailing list, or searching
their archives.

Also, it is critical that you choose the correct mouse driver for your
mouse, regardless of which mouse you have.  I recommend disabling gpm
console mouse driver temporarily, and trying the drivers "Intellimouse",
"ps/2", and others until the proper driver is found.

For X mouse manual page, listing avail drivers: man -a mouse

BTW, this bug was filed against RHL 4.2, I've reassigned it to 7.1 assuming
you mistakenly clicked on 4.2.

After tweaking your settings, does the mouse now work properly?
Comment 2 Josh Olson 2001-09-22 10:25:36 EDT
Ok I've changed the driver to Intellimouse ps/2 but i still get hardlocks, I'm
still searching at xfree86 but I have not come up with much yet. I'm sorry I
mistakenly clicked 4.2 i meant 7.1, I'm still trying a few different mouse
drivers, I'm hoping this works.
Comment 3 Josh Olson 2001-09-24 15:53:04 EDT
ok i'm using the intellimouse driver right now, here is a better analysis of
what happens, sometimes, when xloads the mouse sensitity seems to be very low,
and my mouse moves very slowly. after about 5-10 minutes and it hardlocks the
entire box. A reboot, fixes the problem, and my mouse sensitivity is back to
normal, it will run good on this and not lock x, but after a reboot or two, and
the slowness is back, and it will hardlock for sure.

analysis: sudden slow mouse sensitivity = hardlocked computer;
normal sensitivity works fine, until reboot or two, then slow mouse comes back
and there is hardlock. i have talked to a few people about this, and they are
having same problem
Comment 4 Mike A. Harris 2002-07-29 23:51:13 EDT
I'm having difficulty believing the mouse or mouse driver is causing
hardlocks of your machine.  More likely some other problem is occuring
on the machine, possibly video driver bugs, DRI bugs, or something else,
which is bogging the machine down, killing mouse interactivity, and
eventually locking the box, and you are misinterpreting it as being
a mouse problem.

Please attach your X server log, and config file.  Be sure you are
running the latest XFree86 erratum for Red Hat Linux 7.1.  If you
are using a newer distro release and still having the problem, please
update the distro release number of the bug report if it is still
a relevant issue for you.

Once I've got your logs, I can investigate the problem better.  Please
also attach /var/log/messages from after a crash if you can.
Comment 5 Mike A. Harris 2002-11-10 23:18:51 EST
Due to lack of response for requested information, I am closing this bug
NOTABUG as I can't troubleshoot something without receiving requested
data in a reasonable timeframe.   You're the only person to report such
a problem, and if it were a real software issue, then most likely
I'd be quite inundated with bug reports for this.

I'm writing it off as a hardware problem, or a configuration issue you've
worked around.

Note You need to log in before you can comment on or make changes to this bug.