Bug 539286 - Available translations not shown in sealert
Summary: Available translations not shown in sealert
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 581971
TreeView+ depends on / blocked
 
Reported: 2009-11-19 19:49 UTC by Ville-Pekka Vainio
Modified: 2010-12-04 03:08 UTC (History)
6 users (show)

Fixed In Version: 2.2.60-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 581971 (view as bug list)
Environment:
Last Closed: 2010-12-04 03:08:30 UTC


Attachments (Terms of Use)
Screenshot of sealert with missing translations (86.79 KB, image/png)
2009-11-19 19:49 UTC, Ville-Pekka Vainio
no flags Details

Description Ville-Pekka Vainio 2009-11-19 19:49:12 UTC
Description of problem:
I've translated setroubleshoot completely to Finnish, but some messages which are available in the po/mo file are not shown in the sealert GUI. I'll attach a screenshot to this bug report which shows some of the missing translations, but there are also more.

The ones visible in the screenshot which have translations available in the po/mo file are: "Show all...", "Ignore alert", "Report this Bug..." and "Previous". "Copy to Clipboard" isn't even available in the po/pot file.

I suspect there might be a problem with glade. Maybe the strings in the glade gui elements are marked as translatable, but the translations don't end up in the application when it's running?

Version-Release number of selected component (if applicable):
setroubleshoot-server-2.2.46-1.fc12
setroubleshoot-2.2.46-1.fc12
(from updates-testing, 2.2.42 has the same problem)

Comment 1 Ville-Pekka Vainio 2009-11-19 19:49:58 UTC
Created attachment 372324 [details]
Screenshot of sealert with missing translations

Comment 2 Daniel Walsh 2009-11-19 20:09:24 UTC
If you run sealert -a /var/log/audit/audit.log, does it show with the proper translations?

Comment 3 Ville-Pekka Vainio 2009-11-19 20:40:06 UTC
Running that command as root raises an exception. With the help of abrt I filed another bug about that: https://bugzilla.redhat.com/show_bug.cgi?id=539309

Comment 4 Göran Uddeborg 2009-11-23 21:18:44 UTC
I tried to run your command from comment 2 in a Swedish locale.  It scans the file, but then I get a backtrace which looks very similar to what I reported in bug 484259.  So it appears that it tries to do translations, but it fails for other reasons.

When I configure mails from setroubleshoot, they are not translated either.  Is that the same problem reported here, that alerts are not reported in the GUI?  Or should I file another bugzilla about that?

Comment 5 Daniel Walsh 2009-11-23 21:26:29 UTC
Yes I think the problem is that we have two different tools doing the translations.  setroubleshoot and setroubleshoot-plugins.

I think I have to combine the po files from both into the base package.

Comment 6 Daniel Walsh 2010-01-14 21:53:25 UTC
Please try out

setroubleshoot-plugins-2.1.36-1
setroubleshoot-2.2.55-2

Comment 7 Fedora Update System 2010-01-21 00:04:09 UTC
setroubleshoot-2.2.58-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setroubleshoot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0815

Comment 8 Ville-Pekka Vainio 2010-01-21 16:30:10 UTC
This is not fixed in setroubleshoot-2.2.56-1, waiting for 2.2.58-1 to hit the mirrors.

I can now run sealert -a /var/log/audit/audit.log, but it prints everything in English.

Comment 9 Fedora Update System 2010-01-29 03:31:42 UTC
setroubleshoot-2.2.60-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Ville-Pekka Vainio 2010-01-29 09:08:58 UTC
I think this is still not fixed. I happened to remove all my alerts, so now I can't see all the UI elements, but things like "No alerts to view" and "Show full error output" are still in English. The whole output of sealert -a /var/log/audit/audit.log is also in English. Reopening.

Comment 11 Daniel Walsh 2010-01-29 14:39:42 UTC
Ville, what lanquage setting are you using?

Comment 12 Ville-Pekka Vainio 2010-01-29 15:07:41 UTC
(In reply to comment #11)
> Ville, what lanquage setting are you using?    

Finnish (LANG=fi_FI.UTF-8).

I also tried running LANG=sv_SE.UTF-8 sealert (as root) because I know some Swedish and Göran has used Swedish in Comment 4. The same texts were untranslated. Interestingly, after running LANG=sv_SE.UTF-8 sealert once, I get sealert in Swedish even though I'm trying different languages, such as LANG=de_DE.UTF-8 sealert. All of this is as root. If I run for example LANG=sv_SE.UTF-8 sealert as a regular user, it still starts in Finnish. In addition to translations not showing up, I think there's something weird going on with LANG handling.

Comment 13 Daniel Walsh 2010-02-01 15:39:02 UTC
The problem is in policycoreutils package 

/usr/lib/python2.6/site-packages/seobject.py

It is loading its own translations, which overrides sealerts.

Fixed in policycoreutils-2.0.78-17,
setroubleshoot-2.2.61-1.fc13,
setroubleshoot-plugins-2.1.39-1.fc13

Comment 14 Ville-Pekka Vainio 2010-02-03 09:15:59 UTC
Now sealert -a /var/log/audit/audit.log is in Finnish, which is a step forward, however I still think the UI translations are missing. It is also possible that the original strings have had changes so that the translations don't match anymore, but strings like "Report this Bug" and "Ignore alert" haven't changed.

Comment 15 Daniel Walsh 2010-02-03 14:00:41 UTC
Yes there is a fuzzing problem.  But I have not figured out how to get the tools to accept fuzzy translations.

Comment 16 Ville-Pekka Vainio 2010-02-03 15:53:28 UTC
(In reply to comment #15)
> But I have not figured out how to get the
> tools to accept fuzzy translations.

They probably won't - and shouldn't. I think even non-fuzzy, "good" translations aren't still being shown, but I'm not sure yet. I'll need to "decompile" the .mo file for Finnish and try to see how that looks like, I'll possibly also need to merge it with the current .pot file.

Comment 17 Daniel Walsh 2010-02-03 16:06:07 UTC
Are you sure you have the right stuff,  I think policycorutils might still be broken.


Try 

mv /usr/share/setroubleshoot/plugins/catchall_booleans.* /tmp
Then try sealert in finish.


Mv the files back when you are done.

Comment 18 Ville-Pekka Vainio 2010-02-03 17:09:37 UTC
The instructions in Comment 17 didn't help. I took a look at the source package and it seems the po files are quite old. Still, the fi.po file has non-fuzzy translations for strings such as "Show all..." and "Ignore alert", but those don't show up translated in the GUI. Some translations do, like "Alert <number> of <number>".

Comment 19 Igor Pires Soares 2010-03-30 21:31:14 UTC
The same is happening for pt_BR in Fedora 13 (setroubleshoot-2.2.69-1.fc13.i686). The .PO file on mercurial is fully translated and the .MO appears to be correctly included into the package. Most UI translations from setroubleshoot-framework are missing, although they are translated.

Weirdly, I tried to test sealert in Spanish using LANG=es and it ran in pt_BR anyway.

Comment 20 Daniel Walsh 2010-03-31 14:20:27 UTC
Are the messages translations stored in /var/lib/setroubleshoot/audit_listener_database.xml or are they english?

Comment 21 Igor Pires Soares 2010-04-01 03:44:34 UTC
There are no alerts in my Fedora 13 installation yet, but judging by the one message stored in my Fedora 12 installation, it is in English.

Comment 22 Daniel Walsh 2010-04-01 12:46:03 UTC
When you view it with LANG=es does it show in English?  Was it generated when the machine was running with LANG=es?

Comment 23 Igor Pires Soares 2010-04-01 18:38:21 UTC
Yes, the messages still show in English and the few GUI strings that appear translated show in pt_BR. LANG=locale is totally innocuous. The message was generated when the machine was running pt_BR as the default locale.

Comment 24 Daniel Walsh 2010-04-01 19:37:14 UTC
Igor, can you run

sandbox ls /tmp

To generate an AVC and see if it is translated?

Comment 25 Igor Pires Soares 2010-04-02 05:20:11 UTC
Done, it's is not translated too. Both, on GUI and audit_listener_database.xml.

Comment 26 Ville-Pekka Vainio 2010-04-09 16:38:11 UTC
This was closed as CURRENTRELEASE, which packages are supposed to have the fix? With the setroubleshoot 2.2.69-1 packages on F13 sealert still looks like this: http://vpv.fedorapeople.org/misc/Kuvakaappaus-SELinux_Security_Alerts.png
No translations for Ignore Alert, Copy to Clipboard, Show all... etc.

Comment 27 Daniel Walsh 2010-04-13 14:20:37 UTC
Fixed in setroubleshoot-2.2.72-1.fc13

Comment 28 Fedora Update System 2010-04-13 14:24:22 UTC
setroubleshoot-2.2.72-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/setroubleshoot-2.2.72-1.fc13

Comment 29 Fedora Update System 2010-04-15 03:15:47 UTC
setroubleshoot-2.2.72-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setroubleshoot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/setroubleshoot-2.2.72-1.fc13

Comment 30 Igor Pires Soares 2010-04-16 15:46:29 UTC
This fixes the -plugins internationalization, which is a great improvement, but -framework strings are still bugged, as mentioned on Comment 26.

Comment 31 Daniel Walsh 2010-04-16 17:16:37 UTC
I think these translations are Lanquage specific.  I have seen these translated.

Comment 32 Igor Pires Soares 2010-04-16 18:27:57 UTC
I just tested it with Brazilian Portuguese and Spanish and got the same problems for both languages.

Daniel, are there other specific languages you can tell it is working?

Comment 33 Daniel Walsh 2010-04-20 18:02:36 UTC
I believe this is finally fully fixed in setroubleshoot-2.2.75-1.fc13 

Please try it out and tell me if it works.  If it looks good, I will backport to F12 and put it in RHEL6.

Comment 34 Igor Pires Soares 2010-04-23 18:08:37 UTC
I am running setroubleshoot-2.2.76-1.fc13 and this is really fixed.

I guess it just needs a fine tune, since the string "This alert has occurred <b>%d time</b> since %s" was left out from the current .POT file in Transifex.

Daniel, since this fix generates some new strings and consequently breaks the string freeze, can you rebuilt the package at least once again before the F13 Final Freeze? This will give translators some time to get translations done.

Comment 35 Ville-Pekka Vainio 2010-04-23 19:31:06 UTC
I have no SELinux alerts in the troubleshooter on my F13 system currently. Still, based on "Show full error output" being correctly translated into Finnish in setroubleshoot-2.2.76-1.fc13, I think the technical issues here are mostly solved. If something is missing from the POT file, then that's probably a different kind of bug.

Comment 36 Daniel Walsh 2010-04-26 13:06:01 UTC
I will rebuild setroubleshooter and grab the latest translations.

Comment 37 Bug Zapper 2010-11-04 06:01:01 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 38 Bug Zapper 2010-12-04 03:08:30 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.