Bug 539295 - SELinux is preventing /usr/sbin/NetworkManager "read" access on /var/lib/NetworkManager/NetworkManager.state.
Summary: SELinux is preventing /usr/sbin/NetworkManager "read" access on /var/lib/Netw...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:7e8ad2945e5...
: 550260 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 20:05 UTC by Daniel Qarras
Modified: 2010-10-22 00:30 UTC (History)
5 users (show)

Fixed In Version: 3.6.32-49.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 16:40:41 UTC


Attachments (Terms of Use)

Description Daniel Qarras 2009-11-19 20:05:21 UTC
Summary:

SELinux is preventing /usr/sbin/NetworkManager "read" access on
/var/lib/NetworkManager/NetworkManager.state.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by NetworkManager. It is not expected that this
access is required by NetworkManager and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                /var/lib/NetworkManager/NetworkManager.state [
                              file ]
Source                        NetworkManager
Source Path                   /usr/sbin/NetworkManager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           NetworkManager-0.7.996-7.git20091113.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-127.fc12.i686
                              #1 SMP Sat Nov 7 21:41:45 EST 2009 i686 i686
Alert Count                   4
First Seen                    Thu 19 Nov 2009 09:52:11 PM EET
Last Seen                     Thu 19 Nov 2009 09:54:37 PM EET
Local ID                      2f958517-5af7-4af4-9488-4f543341ea6f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1258660477.688:5): avc:  denied  { read } for  pid=1004 comm="NetworkManager" name="NetworkManager.state" dev=sda6 ino=131710 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1258660477.688:5): avc:  denied  { open } for  pid=1004 comm="NetworkManager" name="NetworkManager.state" dev=sda6 ino=131710 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1258660477.688:5): arch=40000003 syscall=5 success=yes exit=3 a0=80b9a58 a1=8000 a2=0 a3=8545028 items=0 ppid=1003 pid=1004 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-41.fc12,catchall,NetworkManager,NetworkManager_t,var_lib_t,file,read
audit2allow suggests:

#============= NetworkManager_t ==============
allow NetworkManager_t var_lib_t:file { read open };

Comment 1 Daniel Qarras 2009-11-19 20:10:53 UTC
FWIW, I've recently (i.e., before this happened) ran restorecon -v -R /var/lib.

Comment 2 Daniel Walsh 2009-11-19 20:13:22 UTC
COuld you install the selinux-policy package that is in updates-testing to see if this fixes the label on this directory to NetworkManager_var_lib_t

It is either fixed there or

Fixed in selinux-policy-3.6.32-47.fc12.noarch

You can just 

chcon -R -t NetworkManager_var_lib_t /var/lib/NetworkManager

for now

Comment 3 Fedora Update System 2009-11-23 23:37:40 UTC
selinux-policy-3.6.32-49.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-49.fc12

Comment 4 Fedora Update System 2009-11-25 15:20:38 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12131

Comment 5 Fedora Update System 2009-12-02 04:32:11 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Dan Williams 2009-12-26 09:40:50 UTC
*** Bug 550260 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.