Bug 539297 - no sound using phonon-backend-gstreamer
Summary: no sound using phonon-backend-gstreamer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: phonon
Version: 12
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 20:11 UTC by Jeff Bastian
Modified: 2010-01-28 00:57 UTC (History)
12 users (show)

Fixed In Version: 4.3.80-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-28 00:57:48 UTC
Type: ---


Attachments (Terms of Use)

Description Jeff Bastian 2009-11-19 20:11:26 UTC
Description of problem:
After upgrading to Fedora 12, KDE cannot play any sounds or music.  I'm not sure if this is a PulseAudio or a Phonon problem.

If I go to the KDE System Settings Multimedia and select the PulseAudio Sound Server Output Device and then click the Test button to play a test sound, nothing happens.  (The button looks pressed until I click it again, but no sound plays.)

Likewise, if I start Amarok to play music, it says it's playing the song in the status bar, but the progress bar doesn't move and there's no sound.

Totem and Rhythmbox are both able to play music successfully.


Version-Release number of selected component (if applicable):
pulseaudio-0.9.19-2.fc12.x86_64
phonon-4.3.1-102.fc12.x86_64
kdebase-4.3.2-3.fc12.x86_64

How reproducible:
every time

Steps to Reproduce:
1. start KDE
2. go to KDE System Settings -> Multimedia
3. select Music and PulseAudio Sound Server in the Device Preferences
4. click the Test button to play a test sound
  
Actual results:
nothing happens

Expected results:
hear music

Additional info:
Output of 'pulseaudio -vvvv' when trying to play test sound for "PulseAudio Sound Server" via KDE System Settings (with gstreamer backend).

I: client.c: Created 4 "Native client (UNIX socket client)"
D: protocol-native.c: Protocol version: remote 16, local 16
I: protocol-native.c: Got credentials: uid=12257 gid=12257 success=1
D: protocol-native.c: SHM possible: yes                             
D: protocol-native.c: Negotiated SHM: yes                           
D: module-augment-properties.c: Looking for .desktop file for systemsettings
I: client.c: Created 5 "Native client (UNIX socket client)"                 
I: client.c: Freed 4 "<unknown>"                                            
I: protocol-native.c: Connection died.                                      
D: protocol-native.c: Protocol version: remote 16, local 16                 
I: protocol-native.c: Got credentials: uid=12257 gid=12257 success=1        
D: protocol-native.c: SHM possible: yes                                     
D: protocol-native.c: Negotiated SHM: yes                                   
D: module-augment-properties.c: Looking for .desktop file for systemsettings
I: client.c: Freed 5 "<unknown>"                                            
I: protocol-native.c: Connection died.                                      
I: client.c: Created 6 "Native client (UNIX socket client)"                 
D: protocol-native.c: Protocol version: remote 16, local 16                 
I: protocol-native.c: Got credentials: uid=12257 gid=12257 success=1        
D: protocol-native.c: SHM possible: yes                                     
D: protocol-native.c: Negotiated SHM: yes                                   
D: module-augment-properties.c: Looking for .desktop file for systemsettings
I: client.c: Freed 6 "<unknown>"                                            
I: protocol-native.c: Connection died.

Comment 1 Lennart Poettering 2009-11-19 23:52:18 UTC
Looks to be KDE specific. Reassigning, as I have no clue about KDE.

Comment 2 Rex Dieter 2009-11-20 00:01:06 UTC
The test button in systemsettings isn't reliable, don't depend on that really.

amarok not playing... what kind(s) of files (missing required codecs)?

Comment 3 Jeff Bastian 2009-11-20 14:05:32 UTC
I've tried both Ogg and FLAC and neither of them play.  This was on a Lenovo T60 laptop:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

I just tried this on a Dell Optiplex 745 and got the same results:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

I then switched the backend from GStreamer to Xine in KDE System Settings Multimedia and it works.  Maybe this is a problem with Phonon and GStreamer?

Again, totem and rhythmbox both work fine and they're gstreamer apps.  Even ogg123 plays the ogg files from the command line.

Out of curiosity, I just tried Kaffeine from the command line and noticed a bunch of errors about GStreamer:

Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableSubtitlesChanged() in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:57
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAudioChannelsChanged() in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:58
Object::connect: No such signal Phonon::Gstreamer::MediaObject::titleChanged(int) in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:59
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableTitlesChanged(int) in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:60
Object::connect: No such signal Phonon::Gstreamer::MediaObject::chapterChanged(int) in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:61
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableChaptersChanged(int) in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:62
Object::connect: No such signal Phonon::Gstreamer::MediaObject::angleChanged(int) in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:63
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAnglesChanged(int) in /builddir/build/BUILD/phonon-4.3.1/phonon/mediacontroller.cpp:64

Comment 4 Rex Dieter 2009-11-20 14:56:16 UTC
Yeah, phonon-backend-gstreamer + pulseaudio integration and backend switching related to that still leaves a lot to be desired.

(One of the main reasons we're still defaulting to the -xine backend in f12)

Comment 5 Michael Carney 2009-11-26 22:14:57 UTC
Same problem recently happened in F11:

I use juk to listen to MP3 music with Fluendo's MP3 gstreamer plugin, using pulseaudio (and thus the gstreamer backend) in F11. Worked just fine until:

gstreamer-plugins-base-0.10.25-1.fc11.i586
gstreamer-plugins-good-0.10.16-1.fc11.i586

was replaced with:

gstreamer-plugins-base-0.10.25-2.fc11.i586
gstreamer-plugins-good-0.10.16-4.fc11.i586

at which time I started having the exact problem Jeff describes:

I: client.c: Created 10 "Native client (UNIX socket client)"
D: protocol-native.c: Protocol version: remote 15, local 15
I: protocol-native.c: Got credentials: uid=XXXX gid=YYYY success=1
D: protocol-native.c: SHM possible: yes
D: protocol-native.c: Negotiated SHM: yes
D: module-augment-properties.c: Looking for .desktop file for juk
I: client.c: Freed 10 "<unknown>"
I: protocol-native.c: Connection died.

I suppose it's nice that Xine works better than gstreamer, but for those of us that use Fluendo's MP3 plugin, that's cold comfort.

Are those earlier gstreamer rpms I listed above available anywhere? I used to be able to download the previous version of a suspect rpm to root cause problems, but neither download.fedora.redhat.com nor the mirrors appear to have these intermediate rpms anymore. Any clues as to where I might find them?

And barring that, any suggestions for vendors who offer supported MP3 plugins for Xine?

Comment 6 Jeff Bastian 2009-11-30 15:57:33 UTC
(In reply to comment #5)
> Are those earlier gstreamer rpms I listed above available anywhere?

You can find the older packages in the Koji build system:

  http://kojipkgs.fedoraproject.org/packages/gstreamer-plugins-good/
  http://kojipkgs.fedoraproject.org/packages/gstreamer-plugins-base/

Comment 7 Michael Carney 2009-11-30 20:00:57 UTC
Thanks for the Koji hint, Jeff. With that I was able to chase down the problem.

F11 Juk works just fine with Fluendo's MP3 gstreamer plugin with these versions of phonon:


phonon-4.3.1-6.fc11.1.i586.rpm
phonon-backend-gstreamer-4.3.1-6.fc11.1.i586.rpm
phonon-backend-xine-4.3.1-6.fc11.1.i586.rpm

Upgrade to the 4.3.1-102 versions, and you encounter the problem reported by *this* bug.

My guess about the gstreamer-plugins-*- being the cause of the problem was a red herring. The latest versions of these rpms are fine.

Do I need to report *this* bug for F11?

Comment 8 Steven M. Parrish 2009-12-02 19:44:34 UTC
(In reply to comment #7)
> Thanks for the Koji hint, Jeff. With that I was able to chase down the problem.
> 
> F11 Juk works just fine with Fluendo's MP3 gstreamer plugin with these versions
> of phonon:
> 
> 
> phonon-4.3.1-6.fc11.1.i586.rpm
> phonon-backend-gstreamer-4.3.1-6.fc11.1.i586.rpm
> phonon-backend-xine-4.3.1-6.fc11.1.i586.rpm
> 
> Upgrade to the 4.3.1-102 versions, and you encounter the problem reported by
> *this* bug.
> 
> My guess about the gstreamer-plugins-*- being the cause of the problem was a
> red herring. The latest versions of these rpms are fine.
> 
> Do I need to report *this* bug for F11?  

It should be reported against the latest version of Fedora for which it is an issue.  If the issue is in both F11 & F12 report against F12 otherwise F11.

Steven Parrish
KDE & PackageKit Triager

This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 Rex Dieter 2010-01-21 13:09:14 UTC
Also, please retest using the latest phonon in f12 updates (currently, phonon-4.3.80-3 + kde-4.3.4).

Comment 10 Rex Dieter 2010-01-21 14:11:49 UTC
See also,
http://qa.mandriva.com/show_bug.cgi?id=56807

Comment 11 Kevin Kofler 2010-01-22 01:16:51 UTC
This should be fixed in 4.3.80-3 and newer. As Rex Dieter says, please retest.

Comment 12 Fedora Update System 2010-01-22 14:16:35 UTC
phonon-4.3.80-5.fc12,kdebase-runtime-4.3.4-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/phonon-4.3.80-5.fc12,kdebase-runtime-4.3.4-3.fc12

Comment 13 Jeff Bastian 2010-01-25 16:44:11 UTC
The updated packages work for me!  Thanks!

Comment 14 Fedora Update System 2010-01-26 01:00:21 UTC
phonon-4.3.80-5.fc12, kdebase-runtime-4.3.4-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update phonon kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1030

Comment 15 Michael Carney 2010-01-26 17:56:17 UTC
The updated packages work for F11, as well, thanks:

Jan 26 09:50:59 Updated: phonon-4.3.80-5.fc11.2.i586
Jan 26 09:51:02 Updated: kdebase-runtime-libs-4.3.4-3.fc11.i586
Jan 26 09:51:16 Updated: kdebase-runtime-4.3.4-3.fc11.i586
Jan 26 09:51:17 Updated: 2:phonon-backend-gstreamer-4.3.80-5.fc11.2.i586
Jan 26 09:51:17 Updated: phonon-backend-xine-4.3.80-5.fc11.2.i586

Comment 16 Fedora Update System 2010-01-28 00:57:38 UTC
phonon-4.3.80-5.fc12, kdebase-runtime-4.3.4-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.