Bug 539310 - X.org choppy with Intel Graphics
X.org choppy with Intel Graphics
Status: CLOSED DUPLICATE of bug 523646
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
card_GM45
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 15:38 EST by Roy
Modified: 2009-12-04 09:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 09:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.log showing no abnormalities. Default resolution should be 1366x768, but is not related to choppiness. (73.23 KB, text/plain)
2009-11-19 15:38 EST, Roy
no flags Details
Xorg.0.log (3.84 MB, text/plain)
2009-11-20 04:39 EST, Roy
no flags Details
dmesg (44.63 KB, text/plain)
2009-11-20 04:42 EST, Roy
no flags Details

  None (edit)
Description Roy 2009-11-19 15:38:02 EST
Created attachment 372334 [details]
Xorg.log showing no abnormalities. Default resolution should be 1366x768, but is not related to choppiness.

Description of problem:
X.org is choppy after upgrading from F11 to F12. This only occurs when "hybrid graphics" is set to use the Intel GPU, pointing to a problem in the Intel driver. Screen refreshes about 2 times a second. Top shows no abnormal CPU usage, terminal windows respond smoothly. Possibly a timing problem?
Hardware is an Asus UL50Vg, Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller.

Tried setting the AccelMethod to EXA or XAA without luck. Also tried the nomodeset kernel option.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64

How reproducible:
Regular usage

Steps to Reproduce:
1. boot notebook
  
Actual results:
choppy, unusable, slow desktop experience.

Expected results:
Smooth and Shiny desktop experience

Additional info:
Comment 1 Chris Campbell 2009-11-19 19:59:45 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.



This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Roy 2009-11-20 04:39:32 EST
Created attachment 372441 [details]
Xorg.0.log
Comment 3 Roy 2009-11-20 04:42:20 EST
Created attachment 372442 [details]
dmesg
Comment 4 Roy 2009-11-20 04:53:01 EST
Created the attachments, althou I thought I already had an Xorg.0.log. This one is huge for no reason I can think of. I've attached a very interesting dmesg. There is no xorg.conf available in my original setup (althou ofcourse, I've tried several without luck), so I didn't attach one.
To elaborate on the choppiness: bringing up the login window takes about a minute after the Fedora logo is completed (eg. booting completed). Logging in goes quite fast this time, but the desktop takes another 3 minutes to appear after entering the password. And still then, everything (including mouse) is not-really-responsive. None of this happens when using "External Graphics" (nouveau). Bringing up the desktop takes no more than 20 seconds, and everything responds smoothly.
Comment 5 Matěj Cepl 2009-12-04 09:27:47 EST

*** This bug has been marked as a duplicate of bug 523646 ***

Note You need to log in before you can comment on or make changes to this bug.