Bug 539331 - IDELCOUNTER/DPMS bug in vnc server
Summary: IDELCOUNTER/DPMS bug in vnc server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tigervnc
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 21:39 UTC by Jonathan Underwood
Modified: 2013-04-30 23:44 UTC (History)
2 users (show)

Fixed In Version: tigervnc-1.0.0-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-30 16:17:14 UTC
Type: ---


Attachments (Terms of Use)

Description Jonathan Underwood 2009-11-19 21:39:17 UTC
Description of problem:
When running a gnome session in a remote vnc session, gnome-power-manager puts an icon in the toolbar with a hover over message which reads:

"Session active, not inhibited, screen idle. If you can see this text, your display server is broken and you should notify your distributor. Please see http://blogs.gnome.org/hughsie/2009/08/17/gnome-power-manager-and-blanking-removal-of-bodges/ for more information"

If you go to: 

http://blogs.gnome.org/hughsie/2009/08/17/gnome-power-manager-and-blanking-removal-of-bodges/

You can read about the problem that was fixed in the xserver, but presumably still exists in the tigervnc server?



Version-Release number of selected component (if applicable):
tigervnc-server-1.0.0-1.fc12.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Start a gnome session inside vnc
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jonathan Underwood 2009-11-19 21:48:26 UTC
This may be a bug in gnome-power-manager really, since power management inside of a vnc session  is presumably fairly meaningless. Not sure.

Comment 2 Jonathan Underwood 2009-11-19 23:22:21 UTC
Interestingly, I just pulled across the tigervnc-server-1.0.0-3.fc12.x86_64 package from updates testing and restarted the session, and let the screen saver kick in, and now I don't see the icon from gnome-power-manager, so it seems fixed in this package, probably by the change in 1.0.0-2:

- update underlying X source to 1.6.4-0.3.fc11

Will leave this open for now until I'm sure it's fixed.

Comment 3 Adam Tkac 2009-11-30 16:17:14 UTC
If it was a bug in the main X.Org source then this issue should be fixed. Closing.


Note You need to log in before you can comment on or make changes to this bug.