Bug 53937 - gnome-terminal redraws are slow
Summary: gnome-terminal redraws are slow
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-22 20:00 UTC by Ben LaHaise
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-22 21:42:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben LaHaise 2001-09-22 20:00:23 UTC
Redraws in gnome-terminal over a network connection are extremely slow.  
This is easily produced by using a slow network connection, or enabling a 
background image.  On a normal desktop, this can also be reproduced by 
using opaque window movement and watching the clunky redraw in a 
gnome-terminal session.  This behaviour appears to be present in all 7.x 
versions (probably 6.x too).

Comment 1 Havoc Pennington 2001-09-22 22:40:52 UTC
They are a bit slower than they should be, because after several days trying to
get them to work correctly in "optimized mode" we just put it in "redraw
everything all the time" mode. The Zvt codebase is indecipherable, we couldn't
fix simple redraw bugs after much effort.

There is no way to fix this without rewriting the Zvt terminal widget. I don't 
expect to have time to do that in any interesting timeframe. I would suggest
using xterm for remote display for now. Hopefully someone on the net will get a
chance to fix up Zvt.


Note You need to log in before you can comment on or make changes to this bug.