Bug 539379 - [abrt] crash detected in glunarclock-0.32.4-15.fc12
Summary: [abrt] crash detected in glunarclock-0.32.4-15.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glunarclock
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:97931b576c4395a29742224d17d...
: 539391 541552 541929 542469 542523 547185 549211 550219 553588 557582 559294 569913 577359 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-19 23:43 UTC by David Le Sage
Modified: 2010-04-09 04:03 UTC (History)
21 users (show)

Fixed In Version: glunarclock-0.34.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 02:16:57 UTC


Attachments (Terms of Use)
File: backtrace (8.27 KB, text/plain)
2009-11-19 23:43 UTC, David Le Sage
no flags Details

Description David Le Sage 2009-11-19 23:43:07 UTC
abrt detected a crash.

Attached file: backtrace
cmdline: /usr/libexec/glunarclock-applet-2 --oaf-activate-iid=OAFIID:GNOME_GLunarclockApplet_Factory --oaf-ior-fd=42
component: glunarclock
executable: /usr/libexec/glunarclock-applet-2
kernel: 2.6.31.5-127.fc12.i686.PAE
package: glunarclock-0.32.4-15.fc12
rating: 3
reason: Process was terminated by signal 11

Comment 1 David Le Sage 2009-11-19 23:43:10 UTC
Created attachment 372384 [details]
File: backtrace

Comment 2 Gwyn Ciesla 2009-11-20 19:06:15 UTC
*** Bug 539391 has been marked as a duplicate of this bug. ***

Comment 3 Gwyn Ciesla 2009-11-20 19:07:09 UTC
Under what conditions did these crashes occur?

Comment 4 Kerry 2009-11-21 03:12:26 UTC
I get the same crash. It immediately crashes when I try to add it to the panel. I can reproduce it over and over the same way.

Comment 5 David Le Sage 2009-11-22 22:01:18 UTC
Yes, as per the above, I just attempt to add it to the panel and it crashes.

Comment 6 Roger Moore 2009-11-30 06:30:28 UTC
*** Bug 542523 has been marked as a duplicate of this bug. ***

Comment 7 Gwyn Ciesla 2009-11-30 17:31:06 UTC
*** Bug 541929 has been marked as a duplicate of this bug. ***

Comment 8 Gwyn Ciesla 2009-11-30 17:31:11 UTC
*** Bug 542469 has been marked as a duplicate of this bug. ***

Comment 9 Gwyn Ciesla 2009-11-30 17:31:15 UTC
*** Bug 541552 has been marked as a duplicate of this bug. ***

Comment 10 Gwyn Ciesla 2009-11-30 17:32:45 UTC
I see this as well, and am working on it.

Comment 11 Gwyn Ciesla 2009-12-15 15:50:36 UTC
*** Bug 547185 has been marked as a duplicate of this bug. ***

Comment 12 Gwyn Ciesla 2009-12-15 15:57:48 UTC
I tried updating to the cvs checkout from today, and they've upstreamed some of our patches, but it still dies with the same errors in the coredump.

Might this possibly be a glibc bug?  Pardon my ignorance in advance if I'm off base.

CCing glibc maintainer.

Comment 13 Gwyn Ciesla 2009-12-21 13:06:43 UTC
*** Bug 549211 has been marked as a duplicate of this bug. ***

Comment 14 Gwyn Ciesla 2009-12-24 13:12:50 UTC
*** Bug 550219 has been marked as a duplicate of this bug. ***

Comment 15 Gwyn Ciesla 2010-01-08 15:58:10 UTC
*** Bug 553588 has been marked as a duplicate of this bug. ***

Comment 16 Need Real Name 2010-01-19 01:21:18 UTC
Any progress on fixing this bug?

Comment 17 Gwyn Ciesla 2010-01-19 15:46:39 UTC
None on my end, hoping to hear re: glibc.

Comment 18 Ulrich Drepper 2010-01-24 18:54:30 UTC
(In reply to comment #17)
> None on my end, hoping to hear re: glibc.    

Why should this have anything to do with glibc?  Because the crash is in strcmp?  It's *highly* unlikely there is a problem in strcmp, it's used in every single app out there.  It is almost certain that the problem is an invalid pointer or two or unterminated strungs etc.

Comment 19 Gwyn Ciesla 2010-01-25 16:17:23 UTC
It wasn't so much that I suspected glibc, it's that I wanted to rule it out, which was why I sought your input.  You said almost exactly what I thought you'd say, and gave me a general direction in which to shine my flashlight.

Thank you! :)

Comment 20 Gwyn Ciesla 2010-01-25 16:51:12 UTC
*** Bug 557582 has been marked as a duplicate of this bug. ***

Comment 21 Gwyn Ciesla 2010-03-17 20:50:34 UTC
*** Bug 559294 has been marked as a duplicate of this bug. ***

Comment 22 Gwyn Ciesla 2010-03-17 20:50:43 UTC
*** Bug 569913 has been marked as a duplicate of this bug. ***

Comment 23 Fedora Update System 2010-03-17 20:51:51 UTC
glunarclock-0.34.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/glunarclock-0.34.1-1.fc13

Comment 24 Fedora Update System 2010-03-17 20:51:58 UTC
glunarclock-0.34.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/glunarclock-0.34.1-1.fc12

Comment 25 Gwyn Ciesla 2010-03-17 20:52:41 UTC
This is also fixed in rawhide.

Comment 26 Kerry 2010-03-17 21:55:41 UTC
Great, glunarclock-0.34.1-1.fc12.i686.rpm worked for me. Thanks.

Comment 28 Fedora Update System 2010-03-20 03:27:48 UTC
glunarclock-0.34.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glunarclock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/glunarclock-0.34.1-1.fc13

Comment 29 Fedora Update System 2010-03-20 03:40:27 UTC
glunarclock-0.34.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glunarclock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/glunarclock-0.34.1-1.fc12

Comment 30 Spencer Tom Tafadzwa Chirume 2010-03-21 21:45:52 UTC

How to reproduce
-----
1.Start glunarclock 
2. wait for glunarclock to start 
3. or wait for abrt.

Comment 31 b2062407 2010-03-21 22:01:51 UTC

How to reproduce
-----
1. I tried to add this to panel

Comment 32 David 2010-03-22 11:40:26 UTC
FYI new update glunarclock-0.34.1-1.fc12 working now on HP NC6220 Fedora 12

Comment 33 Gwyn Ciesla 2010-03-26 19:39:43 UTC
*** Bug 577359 has been marked as a duplicate of this bug. ***

Comment 34 bagfed 2010-03-27 07:14:08 UTC

How to reproduce
-----
1. add glunarclock to gnome panel

Comment 35 bagfed 2010-03-27 07:16:37 UTC

How to reproduce
-----
1. add glunarclock to gnome panel

Comment 36 David Le Sage 2010-03-29 01:48:34 UTC
Just tried version 0.34.1 in Fedora 13 and I can confirm that, for me, it added to the panel without error.  Thanks for fixing it, Jon!

Comment 37 Gwyn Ciesla 2010-03-29 16:05:24 UTC
Excellent!  Anytime.

Comment 38 Fedora Update System 2010-03-30 02:16:52 UTC
glunarclock-0.34.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 39 Fedora Update System 2010-04-09 04:03:02 UTC
glunarclock-0.34.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.