Bug 539399 - SELinux is preventing /usr/sbin/NetworkManager "read" access on /var/lib/NetworkManager/NetworkManager.state.
Summary: SELinux is preventing /usr/sbin/NetworkManager "read" access on /var/lib/Netw...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:1692e7f20ad...
: 539836 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-20 01:16 UTC by Łukasz Łucka
Modified: 2009-12-02 04:38 UTC (History)
4 users (show)

Fixed In Version: 3.6.32-49.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 16:40:42 UTC


Attachments (Terms of Use)

Description Łukasz Łucka 2009-11-20 01:16:17 UTC
Podsumowanie:

SELinux is preventing /usr/sbin/NetworkManager "read" access on
/var/lib/NetworkManager/NetworkManager.state.

Szczegółowy opis:

SELinux denied access requested by NetworkManager. It is not expected that this
access is required by NetworkManager and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Zezwalanie na dostęp:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Dodatkowe informacje:

Kontekst źródłowy          system_u:system_r:NetworkManager_t:s0
Kontekst docelowy             system_u:object_r:var_lib_t:s0
Obiekty docelowe              /var/lib/NetworkManager/NetworkManager.state [
                              file ]
Źródło                     NetworkManager
Ścieżka źródłowa         /usr/sbin/NetworkManager
Port                          <Nieznane>
Komputer                      (removed)
Źródłowe pakiety RPM       NetworkManager-0.7.996-7.git20091113.fc12
Docelowe pakiety RPM          
Pakiet RPM polityki           selinux-policy-3.6.32-46.fc12
SELinux jest włączony       True
Typ polityki                  targeted
Tryb wymuszania               Enforcing
Nazwa wtyczki                 catchall
Nazwa komputera               (removed)
Platforma                     Linux (removed) 2.6.31.5-127.fc12.x86_64 #1
                              SMP Sat Nov 7 21:11:14 EST 2009 x86_64 x86_64
Liczba alarmów               1
Po raz pierwszy               pią, 20 lis 2009, 01:44:59
Po raz ostatni                pią, 20 lis 2009, 01:44:59
Lokalny identyfikator         c652e388-c760-48b0-8961-0dea81b5dae9
Liczba wierszy                

Surowe komunikaty audytu      

node=(removed) type=AVC msg=audit(1258677899.100:9): avc:  denied  { read } for  pid=1373 comm="NetworkManager" name="NetworkManager.state" dev=dm-0 ino=131102 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1258677899.100:9): arch=c000003e syscall=2 success=no exit=-13 a0=46fa88 a1=0 a2=0 a3=2 items=0 ppid=1372 pid=1373 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-46.fc12,catchall,NetworkManager,NetworkManager_t,var_lib_t,file,read
audit2allow suggests:

#============= NetworkManager_t ==============
allow NetworkManager_t var_lib_t:file read;

Comment 1 Miroslav Grepl 2009-11-20 09:52:06 UTC
For now you can execute

chcon -R -t NetworkManager_var_lib_t /var/lib/NetworkManager


Fixed in selinux-policy-3.6.32-47.fc12.noarch

Comment 2 Miroslav Grepl 2009-11-23 09:11:36 UTC
*** Bug 539836 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2009-11-23 23:37:45 UTC
selinux-policy-3.6.32-49.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-49.fc12

Comment 4 Fedora Update System 2009-11-25 15:20:44 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12131

Comment 5 Fedora Update System 2009-12-02 04:32:16 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.