Bug 539444 - incorrect padding in ssh-dss signature blob encoding
Summary: incorrect padding in ssh-dss signature blob encoding
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libssh2
Version: 12
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL: http://curl.haxx.se/mail/lib-2009-09/...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-20 07:51 UTC by Kamil Dudka
Modified: 2010-02-06 00:05 UTC (History)
3 users (show)

Fixed In Version: 1.2.2-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-06 00:05:33 UTC
Type: ---


Attachments (Terms of Use)

Description Kamil Dudka 2009-11-20 07:51:01 UTC
Description of problem:
http://curl.haxx.se/mail/lib-2009-09/0220.html

Version-Release number of selected component (if applicable):
all curl versions which run SCP/SFTP tests after build

How reproducible:
occasionaly

Additional info:
It looks more likely like a libssh2 issue. More info at the upstream thread and through the links in there.

Comment 1 Kamil Dudka 2009-12-05 19:36:05 UTC
Reported to libssh2 upstream:

http://permalink.gmane.org/gmane.network.ssh.libssh2.devel/2637


The same issue was reported two years ago:

http://sourceforge.net/tracker/index.php?func=detail&aid=1832491&group_id=125852&atid=703942

Comment 3 Kamil Dudka 2009-12-06 15:24:49 UTC
Fixed in libssh2-1.2.2-4.el6 for now.

Comment 4 Fedora Update System 2009-12-23 13:28:47 UTC
libssh2-0.18-10.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libssh2-0.18-10.el5

Comment 5 Fedora Update System 2009-12-23 13:30:26 UTC
libssh2-0.18-10.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/libssh2-0.18-10.el4

Comment 6 David Juran 2009-12-23 13:32:19 UTC
Since I was added to the CC (quite some time ago) I assume the corresponding fixes where request for EPEL as well. Please test and let me know how it fares (-:

Comment 7 Fedora Update System 2010-01-15 22:02:18 UTC
libssh2-1.2.2-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libssh2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0571

Comment 8 Fedora Update System 2010-01-18 23:23:47 UTC
libssh2-0.18-10.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-01-18 23:24:11 UTC
libssh2-0.18-10.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-01-19 06:44:40 UTC
libssh2-1.2.2-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libssh2-1.2.2-4.fc12

Comment 11 Fedora Update System 2010-01-19 19:44:35 UTC
libssh2-1.2.2-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libssh2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0788

Comment 12 Fedora Update System 2010-02-06 00:05:28 UTC
libssh2-1.2.2-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.