Bug 539450 - Xorg crashes when Firefox is reading fedoraforum.org web page
Xorg crashes when Firefox is reading fedoraforum.org web page
Status: CLOSED DUPLICATE of bug 533973
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
12
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 03:28 EST by Michal Zamazal
Modified: 2009-11-23 07:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-23 07:10:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (207.27 KB, text/plain)
2009-11-20 03:28 EST, Michal Zamazal
no flags Details
gdb backtrace as requested (22.27 KB, text/plain)
2009-11-20 08:49 EST, David Wood
no flags Details
xorg.conf (310 bytes, application/octet-stream)
2009-11-20 14:54 EST, Michal Zamazal
no flags Details
Output of dmesg command (27.49 KB, text/plain)
2009-11-20 14:58 EST, Michal Zamazal
no flags Details
output of dmesg (40.42 KB, application/octet-stream)
2009-11-20 23:15 EST, Daniel Belton
no flags Details
xorg log (80.73 KB, application/octet-stream)
2009-11-20 23:21 EST, Daniel Belton
no flags Details
Combined Xorg.log, dmesg and xorg.conf info (113.05 KB, text/plain)
2009-11-23 04:30 EST, David Wood
no flags Details

  None (edit)
Description Michal Zamazal 2009-11-20 03:28:48 EST
Created attachment 372432 [details]
Xorg.0.log

Description of problem:
Xorg crashes when Firefox is reading fedoraforum.org web page. If pictures are blocked in the browser the bug doesn't prove. Also in Konqueror it is OK.

Xorg Radeon drivers, chipset Radeon 9250

Version-Release number of selected component (if applicable):
firefox-3.5.5-1.fc12.i686.rpm

How reproducible:
Start Firefox, open fedoraforum.org - Xorg server crash

Steps to Reproduce:
1. start Firefox
2. open fedoraforum.org
3. effect: Xorg server crash
  
Actual results:
Xorg server crash during viewing the page

Expected results:
viewed web page

Additional info:
Xorg.0.log attached
Comment 1 David Wood 2009-11-20 05:22:00 EST
I've managed to reproduce this Xorg crash on my HP nx9010 when visiting www.fedoraforum.org.  Visiting some other sites with firefox also crashes the X server. I installed kdebase and konqueror works fine.

I have a fresh F12 install, updated today.

From lspci ...

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M

Not sure if this is linked, but I'm seeing this segfault in /var/log/messages ...

kernel: metacity[7812]: segfault at 616d2078 ip 07ff19e1 sp bfb2d830 error 6 in libSM.so.6.0.0[7ff0000+7000]

Also to note, during installation the LCD would 'whiteout' so I had to add 'nomodeset' to the kernel boot line.
Comment 2 Martin Stransky 2009-11-20 07:21:36 EST
Please install all firefox debuginfo packages (debuginfo-install firefox xulrunner), launch firefox, switch to text console (CTRL+ALT+F2) and attach gdb to firefox (gdb --pid=XXX where XXX is a PID of running firefox process). When firefox crashes please attach a backtrace here. (by "thread apply all backtrace" gdb command)
Comment 3 David Wood 2009-11-20 08:49:55 EST
Created attachment 372493 [details]
gdb backtrace as requested

Sorry for the delay. I had to figure out I had to
   a) attach to the /usr/lib/firefox process and not the shell that starts it
   b) type 'continue' into gdb otherwise I don't get anywhere!
   c) 'set logging on' otherwise I can't get the info from the text screen.

Anyway, hope the backtrace is useful.
Comment 4 Martin Stransky 2009-11-20 09:02:55 EST
#3  0x009bbbd8 in __assert_fail (assertion=<value optimized out>, 
    file=<value optimized out>, line=<value optimized out>, 
    function=<value optimized out>) at assert.c:81
#4  0x00143c0a in _XAllocID (dpy=0xb745a000) at xcb_io.c:378
#5  0x003dec48 in XRenderCreatePicture (dpy=<value optimized out>, 
    drawable=<value optimized out>, format=<value optimized out>, 
    valuemask=<value optimized out>, attributes=<value optimized out>)
    at Picture.c:90

...does look like X error. Moving...
Comment 5 Matěj Cepl 2009-11-20 12:02:26 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Michal Zamazal 2009-11-20 14:54:51 EST
Created attachment 372595 [details]
xorg.conf
Comment 7 Michal Zamazal 2009-11-20 14:58:03 EST
Created attachment 372596 [details]
Output of dmesg command
Comment 8 Daniel Belton 2009-11-20 23:15:59 EST
Created attachment 372685 [details]
output of dmesg

I get this same error on every boot after a fresh install of Fedora 12. I am using the nouveau drivers with no xorg.conf file.

I did a fresh install of Fedora 12, and have run a yum update. Other than that, things are as installed. 

(did realize from my dmesg file that I have a hard drive going bad, but that shouldn't cause this in any way since it is a drive not used for linux and formatted ntfs)

any other information I can provide, let me know.

here is the pertinent information from my messages.log file:

Nov 20 21:37:18 tower15 ntpd[1607]: Listening on interface #6 virbr0, 192.168.122.1#123 Enabled
Nov 20 21:37:19 tower15 kernel: [drm] nouveau 0000:01:00.0: Allocating FIFO number 1
Nov 20 21:37:19 tower15 kernel: [drm] nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 1
Nov 20 21:37:21 tower15 kernel: lo: Disabled Privacy Extensions
Nov 20 21:37:27 tower15 kernel: type=1305 audit(1258774647.020:30992): audit_enabled=0 old=1 auid=4294967295 ses=4294967295 subj=system_u:system_r:readahead_t:s0 res=1
Nov 20 21:37:32 tower15 rtkit-daemon[1839]: Sucessfully made thread 1837 of process 1837 (/usr/bin/pulseaudio) owned by '42' high priority at nice level -11.
Nov 20 21:37:33 tower15 rtkit-daemon[1839]: Sucessfully made thread 1843 of process 1837 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 20 21:37:33 tower15 rtkit-daemon[1839]: Sucessfully made thread 1844 of process 1837 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 20 21:37:35 tower15 auditd[1865]: Started dispatcher: /sbin/audispd pid: 1867
Nov 20 21:37:35 tower15 audispd: audispd initialized with q_depth=80 and 1 active plugins
Nov 20 21:37:35 tower15 auditd[1865]: Init complete, auditd 2.0.1 listening for events (startup state enable)
Nov 20 21:37:45 tower15 kernel: metacity[1821]: segfault at 616d2078 ip 002d99e1 sp bfd91760 error 6 in libSM.so.6.0.0[2d8000+7000]
Nov 20 21:37:46 tower15 abrtd: Directory 'ccpp-1258774666-1821' creation detected
Nov 20 21:37:46 tower15 abrtd: Lock file '/var/cache/abrt/ccpp-1258774666-1821.lock' is locked by process 1897
Nov 20 21:37:46 tower15 abrtd: Lock file '/var/cache/abrt/ccpp-1258774666-1821.lock' is locked by process 1897
Nov 20 21:37:46 tower15 abrt: saved core dump of pid 1821 to /var/cache/abrt/ccpp-1258774666-1821/coredump
Nov 20 21:37:47 tower15 abrtd: Getting local universal unique identification...
Nov 20 21:37:47 tower15 abrtd: Crash is in database already
Nov 20 21:37:47 tower15 abrtd: Already saved crash, deleting...
Nov 20 21:37:48 tower15 kernel: fuse init (API version 7.12)
Nov 20 21:37:48 tower15 gnome-session[1902]: EggSMClient-WARNING: Desktop file '/etc/xdg/autostart/esc.desktop' has malformed Icon key 'esc.png'(should not include extension)
Comment 9 Daniel Belton 2009-11-20 23:21:18 EST
Created attachment 372686 [details]
xorg log 

here is my xorg.log as well. didn't see anything in it though. maybe you people will see something.
Comment 10 Kieran Clancy 2009-11-22 06:32:12 EST
I've had X crashes with several different web pages since I upgraded to F12, but not always reliably.

Also, this could be related to bug 539303.
Comment 11 David Wood 2009-11-23 04:30:46 EST
Created attachment 373048 [details]
Combined Xorg.log, dmesg and xorg.conf info

I've pasted relevant info into this attachment, including the whole Xorg.0.log.old file.  Hopefully you'll find the backtrace on line 2032 really useful.
Comment 12 Jérôme Glisse 2009-11-23 07:10:01 EST

*** This bug has been marked as a duplicate of bug 533973 ***

Note You need to log in before you can comment on or make changes to this bug.