Bug 53948 - nnrpd rejects articles with two "cc" headers, but it shouldn't
Summary: nnrpd rejects articles with two "cc" headers, but it shouldn't
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: inn   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-24 03:00 UTC by Jonathan Kamens
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-09 11:54:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-09-24 03:00:25 UTC
When I try to post an article through nnrpd in inn-2.3.2-5 with two "Cc"
headers, it says:

	441 Duplicate "Cc" header

and rejects the article.  While it's true that there are some Usenet
headers which can't be duplicated, "Cc" isn't one of them, especially since
it doesn't have any real significance in a Usenet article (it appears in my
article because I'm both posting and mailing the same message).  This is
therefore an inappropriate reason to reject an article.

Comment 1 Martin Stransky 2005-12-09 11:54:29 UTC
Here is an answer from INN upstream:

> As far as I know we're on shaky ground here with regard to having a  
> specification to follow, but to my eye, we follow the latest USEFOR  
> draft back to RFC 2822.  And RFC 2822 states quite clearly in section  
> 3.6 that the maximum number of Cc headers is 1.  Therefore I don't  
> believe this is a bug, unless someone else feels otherwise?

So I'll close it as WONTFIX, you're the only one who's complaining for it.


Note You need to log in before you can comment on or make changes to this bug.