Bug 53949 - Java Virtual Machine won't build when I try to javac in version 1.3.1
Java Virtual Machine won't build when I try to javac in version 1.3.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kaffe (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-23 23:03 EDT by Lou Rosas
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-23 23:03:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lou Rosas 2001-09-23 23:03:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
I don't know if this is where I should go for this, but I installed Sun's 
version 1.3.1 of the JDK.  I was haveing problems in the compile, so I 
checked which version the Linux box THINKS it is running:  java -version.  
It informed me that it was: version 1.1 and the Kaffe VM.  I rearranged my 
path to put the newly installed version of Java first.  I rebooted and ran 
the java -version command again.  It informed me that I was running 
version 1.3.1 and the Java Hotspot client VM.  When I went to compile a 
file that I was working on I got the error "-X(blah) heap (blah), can't 
create the Virtual Machine".  I don't know what this means.  I don't know 
who to contact on this.  Pleas dirrect me to the appropriate recources in 
the Red Hat community.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install latest JDK (1.3.1)
2. Put so that path sees this "java" command first
3. run "javac <filename>.java"
	

Actual Results:  Get the comment: "-X(blah) heap (blah), 
                  can't create the Virtual Machine"

Expected Results:  The file should have compiled and given me the 
<filename>.class

Additional info:

Please direct me to whom I could contact about this in the Red Hat 
community.
Comment 1 Aleksey Nogin 2002-11-13 07:12:38 EST
Well, if it's a problem with Sun's JVM that's *not* a part of Red Hat Linux,
then the questions should go to Sun, not to Red Hat, right?
Comment 2 Lou Rosas 2002-11-15 11:35:25 EST
NO!  This question should have gone to Red Hat, since this was a problem with 
the setup of the OS.  I had to reinstall the software, and prevent the 
installation of several selected items.  Find someone else to be condescending 
to.

Note You need to log in before you can comment on or make changes to this bug.