Bug 53953 - spec file does not build (on beta5 at least)
spec file does not build (on beta5 at least)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: qt3 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 05:56 EDT by j. alan eldridge
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-25 06:08:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to qt3.spec for %if error, database include paths (7.92 KB, patch)
2001-09-24 05:59 EDT, j. alan eldridge
no flags Details | Diff

  None (edit)
Description j. alan eldridge 2001-09-24 05:56:45 EDT
Description of Problem:
1. There's one too many %endifs, and some of the description stuff is clearly 
messed up anyway (just a bit of cut-n-paste fatigue?).

2. There's path problems on the database stuff. The hack that's there isn't enough, 
as the paths are needed the first time it hits the stuff in the sqldrivers dir. So the 
build bombs out there.

I've fixed this in a way that makes it clear what's going on (unlike some RH spec 
files)....

Patch to spec file attached after I submit this.
Comment 1 j. alan eldridge 2001-09-24 05:59:15 EDT
Created attachment 32499 [details]
patch to qt3.spec for %if error, database include paths
Comment 2 Bernhard Rosenkraenzer 2001-09-25 06:08:04 EDT
Don't use beta3 then, it's known broken. ;)

The %endif thing is actually a bug in our build system - when it tries to 
inject the translations from the i18n cvs tree, it doesn't catch %if/%endif 
constructs affecting %descriptions, therefore it nukes the %endif no matter 
what. :/ The original spec file I'm using is ok.

Fortunately rpm is intelligent enough to handle the missing %endif by now.

Making the SQL plugins optional is a good idea; I'll add that.

(The current build is delayed because I'm waiting for the new compiler to get 
in place first. Breaking the ABI without increasing the soname isn't fun).

Comment 3 Bernhard Rosenkraenzer 2001-10-02 18:17:29 EDT
I've built 0.beta6.1 anyway - it'll probably take too long until the compiler 
is in place (expect some rawhide breakage when it happens).
Fixed in that version.

Note You need to log in before you can comment on or make changes to this bug.