Bug 53955 - custom font support borked
Summary: custom font support borked
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-24 10:02 UTC by j. alan eldridge
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 13:40:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix custom font support in konsole (1.52 KB, patch)
2001-09-24 10:04 UTC, j. alan eldridge
no flags Details | Diff

Description j. alan eldridge 2001-09-24 10:02:21 UTC
Description of Problem:

Custom font support borked in 2.2.1 branch. I backported the patch from 
kdebase/konsole/konsole/konsole.cpp v. 1.176.

[alane@wwweasel alane]$ cat 
Projects/KDE/patches/kdebase/kdebase-2.2.1-konsole.C_1.176_custom_fonts.patch
--- kdebase/konsole/src/konsole.C.custom_fonts  Sat Sep 22 00:45:52 2001
+++ kdebase/konsole/src/konsole.C       Mon Sep 24 05:26:19 2001
@@ -762,7 +762,8 @@
    b_warnQuit=config->readBoolEntry( "WarnQuit", TRUE );
    n_defaultKeytab=config->readNumEntry("keytab",0); // act. the keytab for this 
session
    b_fullscreen = config->readBoolEntry("Fullscreen",FALSE);
-   n_defaultFont = n_font = 
QMIN(config->readUnsignedNumEntry("font",3),TOPFONT);
+   // +1 because we have one more...a custom selected font
+   n_defaultFont = n_font = 
QMIN(config->readUnsignedNumEntry("font",3),TOPFONT+1);
    n_scroll   = 
QMIN(config->readUnsignedNumEntry("scrollbar",TEWidget::SCRRIGHT),2);
    s_word_seps= config->readEntry("wordseps",":@-./_~");
    b_framevis = config->readBoolEntry("has frame",TRUE);
@@ -773,7 +774,8 @@
    // (1) set menu items and Konsole members
    QFont tmpFont("fixed");
    defaultFont = config->readFontEntry("defaultfont", &tmpFont);
-   setFont(QMIN(config->readUnsignedNumEntry("font",3),TOPFONT));
+   // +1 because we have one more...a custom selected font
+   setFont(QMIN(config->readUnsignedNumEntry("font",3),TOPFONT+1));

    //set the schema
    s_kconfigSchema=config->readEntry("schema", "");
@@ -1410,7 +1412,8 @@
   connect( s, SIGNAL( updateTitle() ),
            this, SLOT( updateTitle() ) );

-  s->setFontNo(QMIN(fno, TOPFONT));
+  // +1 because we have one more...a custom selected font
+  s->setFontNo(QMIN(fno, TOPFONT+1));
   s->setSchemaNo(schmno);
   if (key.isEmpty())
     s->setKeymapNo(n_defaultKeytab);
[alane@wwweasel alane]$

Comment 1 j. alan eldridge 2001-09-24 10:04:47 UTC
Created attachment 32500 [details]
fix custom font support in konsole

Comment 2 Ngo Than 2004-09-20 13:40:12 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "CURRENTRELEASE" for now.


Note You need to log in before you can comment on or make changes to this bug.