Bug 53956 - pppd adsl ppp session retained after exit
Summary: pppd adsl ppp session retained after exit
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-24 11:15 UTC by Need Real Name
Modified: 2007-04-18 16:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-08-13 09:30:21 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-09-24 11:15:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
When using pppd with the pty option it is seen that the ppp session is NOT 
terminated on the host machine. This has been tested and verified using 
the benoit ADSL driver with the pppoa2 plugins and pppd 2.4.0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. pppd call adsl (adsl is a peers file)
2. <connection made>
3. killall pppd
	

Actual Results:  1. Connects to the host machine correctly and establishes 
ppp session
2. Once killed does not send a <TERMREQ> to the host machine.

Expected Results:  When a term  signal is sent to pppd it should send a 
<TERMREQ> to the host prior to exiting. It closes the connector BEFORE 
issuing the <TERMREQ>

Additional info:

I have patched main.c;

static void
term(sig)
    int sig;
{
    info("Terminating on signal %d.", sig);
    persist = 0;                /* don't try to restart */
    kill_link = 1;
    status = EXIT_USER_REQUEST;

    // Send the term request now before the connector processes get killed

    lcp_close(0, "User request");

    if (conn_running)
        /* Send the signal to the [dis]connector process(es) also */
        kill_my_pg(sig);
    notify(sigreceived, sig);
    if (waiting)
        siglongjmp(sigjmp, 1);
}

- not the most elegant but did fix the problem, the host debug on ppp 
showed the <TERMREQ> coming in and the session being cleaned up correctly.

Comment 1 Thomas Woerner 2004-08-13 09:30:21 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.