Bug 539586 - Annoying message in Downloads folder
Annoying message in Downloads folder
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-user-share (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 11:54 EST by Christoph Wickert
Modified: 2010-04-08 05:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-08 05:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-user-share-share-bar-check.patch (8.30 KB, patch)
2010-03-10 03:23 EST, Michael Cronenworth
no flags Details | Diff
gnome-user-share-share-extension.patch (1.63 KB, patch)
2010-03-10 03:25 EST, Michael Cronenworth
no flags Details | Diff

  None (edit)
Description Christoph Wickert 2009-11-20 11:54:26 EST
Description of problem:
gnome-user-share displays an annoying message into the "Downloads" folder which takes a large amount of space especially on small screens.

Version-Release number of selected component (if applicable):
gnome-user-share-2.28.1-2.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. start nautilus
2. open your "Downloads" folder
  
Actual results:
Message at the top of the main window:
"Personal File Sharing:
You can receive files over Bluetooth into this folder     Launch Preferences"

Expected results:
The hint is nice, but it should disappear after adjusting the preferences in gnome-file-share-properties because the user has proven he is aware of this option. When receiving files is turned off the message is misleading.
Comment 1 Michael Cronenworth 2009-11-25 00:49:07 EST
I have a machine that does not have this message displayed but I have no idea how to reproduce it on my other machines that do have the message. All machines have gnome-user-share and Bluetooth devices installed and set to accept file downloads. All default folders are present on all systems.

The only discrepancy is that the machine without the message does not have the "emblem" images on my Pictures, Images, and Video folders, but it does for Downloads, Documents, and Public. The machine with the message has emblems on all default folders. Where are those emblems assigned? I haven't seen anything in gconf about them.
Comment 2 Matthias Clasen 2009-11-25 01:38:24 EST
xdg-user-dirs defines what the 'Downloads' folder is. See ~/.config/user-dirs.dirs
Comment 3 Michael Cronenworth 2009-11-25 02:02:03 EST
(In reply to comment #2)
> xdg-user-dirs defines what the 'Downloads' folder is. See
> ~/.config/user-dirs.dirs  

Thanks. Setting the values for Music, Pictures, and Video on the system without the message made the emblems appear, but the Download folder is still without the message.
Comment 4 Matthias Clasen 2009-11-25 10:51:26 EST
Is it 'Download' or 'Downloads' ? The name changed between F11 and F12.
Comment 5 Christoph Wickert 2009-11-25 10:55:09 EST
For me it's 'Downloads', but I have been upgrading from F11 and also I use de_DE.UTF-8.
Comment 6 Matthias Clasen 2009-11-25 11:09:10 EST
Here is a bug about fine-tuning of the message: 

https://bugzilla.gnome.org/show_bug.cgi?id=602951
Comment 7 Michael Cronenworth 2009-11-25 15:33:07 EST
(In reply to comment #4)
> Is it 'Download' or 'Downloads' ? The name changed between F11 and F12.  

I use 'Download' on the two systems I have mentioned. I have created a '~/Downloads' folder on the machine without the message, but there is no message when I view that folder either. If I create a '~/Downloads' on the machine with the message I do not see the message in the new folder, but I still see it in Download.

Instead of changing the text of this message, please add a check-box to totally remove it. I don't know how my one machine is not displaying the message what-so-ever though.
Comment 8 markm 2010-03-06 13:32:29 EST
I would like to get rid of this message too - it's annoying, takes way too much space and in most cases is not needed. There should be an option to remove it permanently.
Comment 9 Christoph Wickert 2010-03-06 13:45:24 EST
Changing version to 'rawhide' because I don't expect this to be fixed any time soon.
Comment 10 Michael Cronenworth 2010-03-10 03:23:37 EST
Created attachment 399025 [details]
gnome-user-share-share-bar-check.patch

(In reply to comment #9)
> Changing version to 'rawhide' because I don't expect this to be fixed any time
> soon.  

Ewww! Not good enough I say. :P

I finally broke down (in tears) and wrote a patch(s). :D

The first patch creates a checkbox in the preferences and a boolean in the schema.
Comment 11 Michael Cronenworth 2010-03-10 03:25:53 EST
Created attachment 399027 [details]
gnome-user-share-share-extension.patch

The second patch adds the boolean check to the share-extension.c module.

The other folder bars (Public, etc.) could be added using my patches as a template.
Comment 12 Bug Zapper 2010-03-15 09:16:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bastien Nocera 2010-04-08 05:17:13 EDT
Closing this as upstream, as it's being discussed there.

https://bugzilla.gnome.org/show_bug.cgi?id=602951

Note You need to log in before you can comment on or make changes to this bug.