Bug 539608 - [abrt] crash detected in whaawmp-0.2.12.1-2.fc12
Summary: [abrt] crash detected in whaawmp-0.2.12.1-2.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: whaawmp
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Spura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:eaf03a80
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-20 17:28 UTC by hacataka
Modified: 2009-12-07 07:27 UTC (History)
2 users (show)

Fixed In Version: 0.2.12.1-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-07 07:27:15 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (889 bytes, text/plain)
2009-11-20 17:28 UTC, hacataka
no flags Details
proposed patch (792 bytes, patch)
2009-11-21 13:51 UTC, Thomas Spura
no flags Details | Diff

Description hacataka 2009-11-20 17:28:32 UTC
abrt detected a crash.

Attached file: backtrace
cmdline: python /usr/lib/python2.6/site-packages/whaawmp/whaawmp.py 
component: whaawmp
executable: /usr/lib/python2.6/site-packages/whaawmp/whaawmp.py
kernel: 2.6.31.5-127.fc12.x86_64
package: whaawmp-0.2.12.1-2.fc12
uuid: eaf03a80

Comment 1 hacataka 2009-11-20 17:28:35 UTC
Created attachment 372554 [details]
File: backtrace

Comment 2 Christoph Wickert 2009-11-20 17:50:27 UTC
Can you tell me what you were doing when whaawmp crashed?

Comment 3 Thomas Spura 2009-11-21 13:51:29 UTC
Created attachment 372735 [details]
proposed patch

When this patch is applied, it is checked if the current queue is empty. If it is empty, the programm does not try to play anything. Before it tried to play a random entry from an empty list -> crash.

I tried to reproduce this problem, but it didn't not work...
Don't know where you actually clicked on.

Comment 4 Fedora Update System 2009-11-21 15:43:06 UTC
whaawmp-0.2.12.1-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/whaawmp-0.2.12.1-3.fc12

Comment 5 Fedora Update System 2009-11-24 07:50:55 UTC
whaawmp-0.2.12.1-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update whaawmp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11958

Comment 6 Fedora Update System 2009-12-07 07:27:10 UTC
whaawmp-0.2.12.1-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.